Thunderbird sentry check needs further tweak

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: nthomas, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
From https://nagios.mozilla.org/sentry/logentry.cgi?id=257&time=2010-05-04%2004:17:43

Checking /thunderbird/releases/3.1b1/mac/zh-TW/Lanikai%203.1%20Beta%201.dmg... okay.
Checking /thunderbird/releases/3.1b1/linux-i686/zh-TW/lanikai-3.1b1.tar.bz2... okay.
Checking /thunderbird/releases/3.1b1/win32/zh-TW/Lanikai%20Setup%203.1%20Beta%201.exe... okay.
Checking /thunderbird/releases/3.1b1/update/mac/zh-TW/lanikai-3.1b1.complete.mar... okay.
Checking /thunderbird/releases/3.1b1/update/linux-i686/zh-TW/lanikai-3.1b1.complete.mar... okay.
Checking /thunderbird/releases/3.1b1/update/win32/zh-TW/lanikai-3.1b1.complete.mar... okay.
Checking /thunderbird/releases/3.1b1/update/mac/tr/lanikai-3.1a1-3.1b1.partial.mar... FAILED. rc=404
Checking /thunderbird/releases/3.1b1/update/linux-i686/tr/lanikai-3.1a1-3.1b1.partial.mar... FAILED. rc=404
Checking /thunderbird/releases/3.1b1/update/win32/tr/lanikai-3.1a1-3.1b1.partial.mar... FAILED. rc=404

The problem is matching on filepath to broadly:
         elsif ($filepath =~ m!/thunderbird/!) {
            if ($filepath =~ m!3\.1a1!) {
                $filepath =~ s@:lang@tr@;
            }
            else {
                $filepath =~ s@:lang@zh-TW@;
            }
         }

It should work properly if we match on /3.1a1/, with appropriate escaping.
(Reporter)

Comment 1

9 years ago
Where the problem is that 'tr' doesn't exist for 3.1b1, and we should be checking the zh-TW locale for the partials.
I believe we got around this ages ago and 3.1b1 is kinda old now anyway.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.