Closed Bug 563639 Opened 9 years ago Closed 9 years ago

crashtest: intermittent "382778-1.html | timed out waiting for ..." probably caused by "targetDocument.body is null"

Categories

(Core :: Editor, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla1.9.3a5
Tracking Status
blocking2.0 --- -

People

(Reporter: sgautherie, Assigned: ehsan)

References

(Blocks 1 open bug, )

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1272892883.1272893817.9521.gz
Linux comm-central-trunk debug test crashtest on 2010/05/03 06:21:23
s: cb-seamonkey-linux-03
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1272938966.1272940571.16362.gz
Linux comm-central-trunk debug test crashtest on 2010/05/03 19:09:26
s: cb-sea-linux-tbox
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1272972402.1272973903.6674.gz
Linux comm-central-trunk debug test crashtest on 2010/05/04 04:26:42
s: cb-sea-linux-tbox
{
JavaScript error: file:///builds/slave/comm-central-trunk-linux-debug-unittest-crashtest/build/reftest/tests/editor/libeditor/html/crashtests/382778-1.html, line 26: targetDocument.body is null

REFTEST TEST-UNEXPECTED-FAIL | file:///builds/slave/comm-central-trunk-linux-debug-unittest-crashtest/build/reftest/tests/editor/libeditor/html/crashtests/382778-1.html | timed out waiting for reftest-wait to be removed (after onload fired)
}

I assume this is a recent regression, though I didn't do an extensive history check.
Blocks: SmTestFail
OS: Linux → All
Summary: [(Debug) Linux SeaMonkey] crashtest: intermittent "382778-1.html | timed out waiting for ..." probably caused by "targetDocument.body is null" → [Debug] crashtest: intermittent "382778-1.html | timed out waiting for ..." probably caused by "targetDocument.body is null"
Attached patch Patch (v1)Splinter Review
The first setTimeout isn't necessary, since we just want to wait for the iframe to be loaded.  Removing that fixes the random orange.  The second setTimeout is (I assume) just there to give us a chance to hit the event loop, and 0 would do just fine for that.  Changing that to 0 makes the crashtest suite complete 100ms faster.  :-)
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
Attachment #447629 - Flags: review?(roc)
Summary: [Debug] crashtest: intermittent "382778-1.html | timed out waiting for ..." probably caused by "targetDocument.body is null" → crashtest: intermittent "382778-1.html | timed out waiting for ..." probably caused by "targetDocument.body is null"
http://hg.mozilla.org/mozilla-central/rev/7153afde1b42
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a5
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.