MacOS 10.4 only - drop down arrow disappears from select field after javascript sets classname to set background-color

RESOLVED INCOMPLETE

Status

()

RESOLVED INCOMPLETE
9 years ago
8 years ago

People

(Reporter: hamishnospam, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-1-30])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OSX 10.4; en-US; rv:1.9.?) Gecko/2010031218 Firefox/3.6.3

Affects MacOS 10.4 Firefox only:
When using javascript to set class of select field (selectBox.className='yel') or to set background color (selectBox.style='background-color:#FFFFAA') field loses drop-down arrow on Mac FF.
Works fine in Windows Firefox and on MacOS 10.5 (both FF 3.0.19 and 3.6.3 tested OK on MacOS 10.5)

Reproducible: Always

Steps to Reproduce:
1. Check your Mac is running MacOSX 10.4
2. Execute some javascript that sets the className of a select box, in order to change the color of the select box.
Example HTML (demonstrates issue on page load:
<html>
<head>
<style>
.yel {background-color: Yellow;}
</style>
</head>
<body onload="document.getElementById('select1').className='yel';">
<select id="select1">
<option></option>
<option value="1">Option 1</option>
</select>
</body>
</html>
Actual Results:  
When select box turns yellow, drop down arrow disappears, so it is not obvious that the field is a select box

Expected Results:  
select box should change color without losing the drop down arrow
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles

You can also try to reproduce in Firefox 4 Beta 8 or later, there are many improvements in the new version, http://www.mozilla.com/en-US/firefox/all-beta.html
Whiteboard: [CLOSEME 2011-1-30]
No reply, INCOMPLETE. Please retest with Firefox 3.6.13 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.