regprot.exe can damage Windows registry

RESOLVED FIXED

Status

RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: matthew.gertner, Assigned: matthew.gertner)

Tracking

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
See http://browsing.justdiscourse.com/2008/06/14/update-prism-test-version-for-windows/. I thought I had nailed this problems ages ago, but I just received a couple of reports that it is still occurring in 1.0b3.
(Assignee)

Comment 1

8 years ago
Created attachment 443655 [details] [diff] [review]
Just overwrite the existing info instead of deleting it first

The problem is that a user clicking on regprot.exe causes it to run with /Protocol set to an empty string (at least that's my assumption). So the whole registry classes root gets deleted. Why there isn't an error when no /Protocol is found is not clear to me, but I've removed the DeleteRegKey call just to be totally safe.
Assignee: nobody → matthew.gertner
Status: NEW → ASSIGNED
Attachment #443655 - Flags: review?(mark.finkle)
(Assignee)

Updated

8 years ago
Attachment #443655 - Attachment is patch: true
Attachment #443655 - Attachment mime type: application/octet-stream → text/plain
Attachment #443655 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 2

8 years ago
Sending        client/winbuild/regprot.nsi
Sending        confvars.sh
Transmitting file data ..
Committed revision 67049.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.