ISO-8859-1 should be converted as CP 1252

VERIFIED FIXED in M4

Status

()

Core
Internationalization
P2
normal
VERIFIED FIXED
20 years ago
19 years ago

People

(Reporter: Paul MacQuiddy, Assigned: cata)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: have fix in local build, wait for bug meeting to approve check in., URL)

(Reporter)

Description

20 years ago
There are several blank lines where there should be text in the article at
http://www.microsoft.com/presspass/features/7-23realnet.htm

Comment 1

20 years ago
Rick, I think this is a parser problem.

Comment 2

20 years ago
The content model has the text in place; it's not a parser problem but must
be a layout problem instead...

Comment 3

20 years ago
The missing text contains octal 222 characters which trigger our text
code going into the "it's unicode" path which is not yet implemented.

Updated

20 years ago
Assignee: kipp → kostello
Component: Unknown → Rendering

Comment 4

20 years ago
The problem with the text code not rendering unicode data has been fixed.

Now the problem is that the rendering system (gfx) doesn't know how to
handle unicode rendering properly (it needs to support the font set
abstractions from navigator so that different ranges of characters can
select into different fonts since most fonts don't support the entire
unicode character set). That's why I'm reassigning the bug to greg since
he's now been tagged as libfont boy :-)

Updated

20 years ago
Assignee: kostello → kipp

Updated

20 years ago
Assignee: kipp → kostello

Comment 5

20 years ago
Trying to reassign *again*

Updated

20 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Assignee: kostello → troy
Status: ASSIGNED → NEW

Comment 6

19 years ago
Troy -- I'm not sure who on your team is handling this now -- could you please
reassign to the appropriate person. Thanks.

Updated

19 years ago
Assignee: troy → rickg

Comment 7

19 years ago
Who handled libfont?

Updated

19 years ago
Assignee: rickg → michaelp

Comment 8

19 years ago
Sparky: I'm giving this *hot potato* to you, since it involves complex fonts.
Keep this as a placeholder until the i18n guys fix the font stuff.

Comment 9

19 years ago
Setting all current Open/Normal to M4.

Updated

19 years ago
Assignee: michaelp → bobj
Component: Compositor → Internationalization

Comment 10

19 years ago
changing the component to i18n since this deals with unicode related font
issues. Also, I sent a side note to i18n QA asking who should be qa assigned.
Changing assigned to - to bobj

Updated

19 years ago
QA Contact: 3851

Updated

19 years ago

Comment 11

19 years ago
1. update the URL to the right one
2. reassign to erik

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Summary: Missing lines of text → Window GFX Unicode Text Drawing- Missing lines of text

Updated

19 years ago
Assignee: erik → ftang
Status: ASSIGNED → NEW

Comment 12

19 years ago
Octal 222 is decimal 146, hex 92, name RIGHT SINGLE QUOTATION MARK. This code
is part of CP 1252 (windows-1252). The Windows GFX font engine can display this
character, so it must be the parser or scanner that is not properly converting
from CP 1252 to Unicode. Re-assigning to ftang. Frank, are you working on this
part?

Updated

19 years ago
Assignee: ftang → cata
Summary: Window GFX Unicode Text Drawing- Missing lines of text → ISO-8859-1 should be converted as CP 1252
Target Milestone: M4 → M5

Comment 13

19 years ago
Change the summary to "ISO-8859-1 should be converted as CP 1252" from "Missing
line of text"

Cata, we should use cp1252.uf and cp1252.ut to deal with ISO-8859-1 charset.
Mark it as M5.

Updated

19 years ago
Target Milestone: M5 → M4

Comment 14

19 years ago
*** Bug 4551 has been marked as a duplicate of this bug. ***

Comment 15

19 years ago
change back to M4
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Whiteboard: have fix in local build, wait for bug meeting to approve check in.

Comment 16

19 years ago
fixed and check in

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 17

19 years ago
Teruko, this looks fixed to me... I'll leave it to you to verify it though.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 18

19 years ago
I verified this in 4-26-8 Win32 build.
You need to log in before you can comment on or make changes to this bug.