TM: Implement arena pool chunk time-deferred "soft release"

RESOLVED DUPLICATE of bug 684039

Status

()

Core
JavaScript Engine
P5
enhancement
RESOLVED DUPLICATE of bug 684039
8 years ago
7 years ago

People

(Reporter: cdleary, Assigned: cdleary)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

Never filed a bug for this -- an interesting experiment stemming from bug 561286:

"""you can use time locality to let the arenas sit and age until
the next garbage collection. For imacro_asm, this seems particularly useful in
regular expression evaluation."""
Assignee: general → cdleary
Adding reference to regexp pool fix bug. I've actually implemented and tested a single-big-chunk arena strategy that shows no speedup in the shell, but still has to be tested in browser. Will post patches for that tomorrow.
Status: NEW → ASSIGNED
Depends on: 586827
Created attachment 467453 [details] [diff] [review]
Experiment: Fat arena.

Make an arena template class in arenang.h that just uses a huge primary chunk. For this part of the experiment I just made it sufficiently huge that secondary chunks are unnecessary for benchmark runs.
Created attachment 467463 [details] [diff] [review]
Experiment: Fat arena.

It helps when you add new files...
Attachment #467453 - Attachment is obsolete: true
Created attachment 467465 [details] [diff] [review]
Experiment: Fat arena.

Rebase.
Attachment #467463 - Attachment is obsolete: true
To do: we can also eliminate all the emit checks with a sufficiently large single primary chunk.
Severity: normal → enhancement
My observation was that this wouldn't give us much of a speedup, so I'm downgrading to my "cleanup" priority. :-)
Priority: -- → P5
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 684039
You need to log in before you can comment on or make changes to this bug.