Closed Bug 564075 Opened 11 years ago Closed 11 years ago

Url bar gets displaced, with open sidebar, focusing url bar and then dismissing awesome bar

Categories

(Firefox for Android Graveyard :: General, defect)

x86
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: martijn.martijn, Assigned: vingtetun)

References

Details

Attachments

(2 files)

Attached image screenshot
To reproduce:
- Pan left to open the sidebar
- Tap the url bar, the awesome bar popup opens
- Dismiss it by tapping on the top right button

Result:
The url bar is displaced, it doesn't extend anymore over the sidebar as it usually does. See screenshot of what I mean.

I can reproduce this on a n900 Fennec from 2010-05-05 1.9.2.5pre.
I couldn't reproduce it on windows, for some reason, though.
This is a regression caused by bug 537717. I'm working on it.
Assignee: nobody → 21
Attached patch PatchSplinter Review
This patch should be more robust and prevent that.

It also include a fix for that prevent opening the urlbar for just a onmouseup (introduce in bug 557619) which is annoying on device when the sidebars are open and we pan fast by releasing the finger on the urlbar!
Attachment #443866 - Flags: review?(mark.finkle)
Comment on attachment 443866 [details] [diff] [review]
Patch

Patch looks good and should be more robust than the current code.

I wish there was a way to test this better. We have had too much breakage from changes like this.
Attachment #443866 - Flags: review?(mark.finkle) → review+
Blocks: 537717
pushed m-b:
http://hg.mozilla.org/mobile-browser/rev/a2e656e33376

pushed m-1.1:
http://hg.mozilla.org/releases/mobile-1.1/rev/54e433fbd370
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
verified FIXED on builds:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2.5pre) Gecko/20100507 Namoroka/3.6.5pre Fennec/1.1b2pre

and

Mozilla/5.0 (X11; U; Linux armv71; Nokia N900; en-US; rv:1.9.3a5pre) Gecko/20100507 Namoroka/3.7a5pre Fennec/2.0a1pre
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.