Firefox stores browsing history even a page is 404 not found

RESOLVED DUPLICATE of bug 322511

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED DUPLICATE of bug 322511
8 years ago
8 years ago

People

(Reporter: Michael Tsang, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.3) Gecko/20100423 Ubuntu/10.04 (lucid) Firefox/3.6.3
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.3) Gecko/20100423 Ubuntu/10.04 (lucid) Firefox/3.6.3

When I mis-typed an URL and went to a 404 page, Firefox stores the mis-typed URL. This is a bad user experience.

Reproducible: Always

Steps to Reproduce:
1.Type an nonexistant URL and go to a 404 page
2.Type a part of that URL again

Actual Results:  
It shows the nonexistant URL again.

Expected Results:  
It shouldn't store that URL.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 322511
You need to log in before you can comment on or make changes to this bug.