In-page element given minimum width

RESOLVED DUPLICATE of bug 473352

Status

RESOLVED DUPLICATE of bug 473352
9 years ago
9 years ago

People

(Reporter: mozilla, Assigned: mkaply)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.3) Gecko/20100503 Gentoo Firefox/3.6.3
Build Identifier: 

If an hcard microformat is present (an element with class 'vcard') that containing an element with class 'fn', the hcard is given a minimum width of 638 pixels.

Test case follows. The green div is for reference. With the 'fn' class present the red div will not resize smaller than the green div when the browser is resized. If the 'fn' class is removed then it will.

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en">
<head>
  <title>Operator 0.9.5.1 bug test</title>
  <style type="text/css">
    .reference {
      border: 1px solid green;
      width: 638px;
    }
    .vcard {
      border: 1px solid red;
    }
  </style>
</head>
<body>
  <div class="reference">
    <span>Full Name</span>
  </div>
  <div class="vcard">
    <span class="fn">Full Name</span>
  </div>
</body>
</html>


Reproducible: Always

Steps to Reproduce:
1. Visit a page with an hCard that contains an element with the 'fn' class.
2. Reduce the width of the browser window.
3. The hCard won't resize below 638 pixels width.
Actual Results:  
hCard has minimum width of 638 px.

Expected Results:  
hCard should have continued to reduce in size below 638 px width.
(Reporter)

Comment 1

9 years ago
Forgot to say that it's Operator 0.9.5.1 on Firefox 3.6.3.
I'm not sure what this problem has to do with Operator? This sounds like a general rendering problem.

Does it only happen with Operator installed?
(Reporter)

Comment 3

9 years ago
Yep - If I disable Operator the problem goes away. It also doesn't seem to happen with other hCard classes that I've used (title, org, url, email, tel).

I found the problem when I was doing some CSS work on a web page. It got very confusing when this minimum height was occurring when my CSS shouldn't have been responsible for it. I tried on three different browsers and eventually narrowed it down to the presence of Operator and the 'fn' class.

I wondered whether Operator was restyling certain elements for some disabled functionality, like its feature to highlight Microformats.

If it's a surprise to you I'll try disabling every other addon and try with Operator alone.
Strange. I'm not seeing the problem with Operator only. The bottom div will go smaller than the top green div.

If you could try it with Operator alone, that would be great.

Do you see the bottom DIV stay at exactly the same width as the top div?
(Reporter)

Comment 5

9 years ago
I've tested with only the Operator addon installed and the problem still exists, but I've identified an indirect cause for which I'm unsure of the culprit. It suspect it's a Firefox bug in its extension features.

The problem only happens when the Operator location bar icon is enabled. The bottom div should resize all the way down to the text (which should wrap) but it won't when the icon is enabled.

In the browser I first tried, the bottom div would stay the same width as the top div. Now though, in my test browser, the div will resize to less than 638px (but still all the way down), which must be due to the fact I've got less buttons in the location bar on this browser.

I'll see if I have any other extensions that allow me to add an icon to the location bar and test with them.
(Reporter)

Comment 6

9 years ago
edit: (but still *not* all the way down)
(Reporter)

Comment 7

9 years ago
It's a Firefox bug. It also happens when the RSS icon is in the location bar. Sorry for the false report.
Are you on Mac by chance?
(Reporter)

Comment 9

9 years ago
I'm on Linux. Why?

Btw, the bug occurs with any div when Firefox has a location bar icon - it's not just the 'fn' class (I probably got that idea because that's when the operator icon would appear). I'll check the Firefox bug tracker and post a report if there isn't one already.
The reason I asked is because there is a separate Mac bug where when the window reaches a certain minimum width, content just stops resizing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 473352
You need to log in before you can comment on or make changes to this bug.