Split the SPARC compilation up between both build slaves

VERIFIED FIXED in Q3 11 - Serrano

Status

VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: brbaker, Assigned: jsudduth)

Tracking

unspecified
Q3 11 - Serrano
Sun
Solaris
Bug Flags:
flashplayer-qrb +
flashplayer-triage +

Details

(Whiteboard: build-speedup, buildbot)

(Reporter)

Description

9 years ago
We could trim 6 minutes off of the SPARC compilation time by splitting the compile phase up between both of the solaris-sparc build slaves.

This will require a little more work than just juggling build config (will require local build-check and upload scripts).

Second SPARC machine is slower, but moving a couple of compilation steps to it will be a net gain in reducing the SPARC compilation phase

Build Step              Current asteamsol4  asteamsol3  Difference
Source_Clean            54      54          63
Source_Clone            126     126         118
Source_Update           1       1           1
BB_SLAVEUpdate          0       0           0
Compile_builtin.abc     31      31          38
Build_Release           188                 244
Build_Release-wordcode  178                 236
Build_Debug             208     208        
Build_ReleaseDebugger   200     200        
Build_DebugDebugger     225     225        
Build_Check             0       0           0
Upload_ASTEAM           5       5           5
Upload_MOZILLA          54      54
                        21.17   15.07       11.75       6.10
Flags: flashplayer-triage+
Flags: flashplayer-qrb?

Updated

9 years ago
Summary: [buildbot] Split the SPARC compilation up between both build slaves → Split the SPARC compilation up between both build slaves
Whiteboard: build-speedup → build-speedup, buildbot

Updated

9 years ago
Duplicate of this bug: 562728

Updated

9 years ago
Assignee: nobody → jsudduth
Flags: flashplayer-qrb? → flashplayer-qrb+
Target Milestone: --- → flash10.2

Updated

9 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 2

9 years ago
This /might/ not be worth the work to split up. We used to have a time limit of 20 minutes for the compile phase and this is just over that mark. There are about another 3 build slaves that are in the 19-20 minute range so even doing this work will not be a huge win... not to say that shaving off a minute or so is not a win, just not huge like recent build time savings
(Assignee)

Comment 3

8 years ago
Should I go ahead and fix this in light of comment #2?

Comment 4

8 years ago
its a question of IF vs WHEN.

IF: of course. we need to be striving to lower build times.  (20 minutes now, 10 later, and so on).

WHEN: Comment #2 implies there could be something more important to do before this.  If so, sure, I have no opinion. If you press me for an opinion: unless there is a blocking issue, I'd just go for this now so we dont have to worry about it later.
(Reporter)

Comment 5

8 years ago
Closing this bug since SPARC build/testing was optimized in bug #623609

Fixed via changeset 5802:c82ece99d8e0 and 5814:e270f9eeca30
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.