Live Bookmark status menuitem persists in menus

VERIFIED FIXED in Firefox 3.7a5

Status

()

--
major
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: jmjeffery, Assigned: mak)

Tracking

({regression})

Trunk
Firefox 3.7a5
x86
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Open the bookmarks from the Bookmarks Menu Item 
Click on the Live Bookmarks 
Choose one in the list and right-click ->  'Reload Live Bookmark'
Notice that the 'loading live bookmark' never goes away.

Regression from:
https://bugzilla.mozilla.org/show_bug.cgi?id=528884

Tested with today's m-c nightly build on Win7 x64
(Assignee)

Updated

9 years ago
Blocks: 560198

Comment 1

9 years ago
Same with x86 on WindowsXP.
Summary: Livemark update stuck in 'loading...' → Live Bookmark update stuck in 'loading...'
moreover i'm not able to copy/delete/cut the live bookmark container (e.g. put on bookmarks tooolbar) via context menu or put an other container (e.g. cut/copied from library - where cutting/deleting/pasting still works) on the bookmarks toolbar.

should i rather file a new bug for this?
(Assignee)

Comment 3

9 years ago
anything reported in the error console?
(In reply to comment #3)
> anything reported in the error console?

nothing at all
(In reply to comment #2)
there was no error console output. thus i excluded extension breaking issues at first.
now after disabling
"Auto Copy 1.0.1", "BBCode 0.5.3.1", "Close by Double Click 1.12", "CoLT 2.4.7", "Console 0.7a1" & "Copy Plain Text 0.3.3" and restarting, deleting that container type worked again. then i enabled each extension one-by-one to find the culprit, but even after enabling them all it still works (what is kinda weird). so in the end: sorry for hijacking/spamming this report.
I just restarted my PC and left Minefield open for awhile, I suppose given it had a chance to refresh live bookmarks using today's nightly on win7, I now have 2 items at the top of my mozillazine daily trunk build RSS thread showing "Live bookmark loading..." and I have the most current item in the list already at the top.  

using http://pipes.yahoo.com/pipes/pipe.info?_id=17e1ec1625fca5fde4143a54032b1bc5
(In reply to comment #4)
> (In reply to comment #3)
> > anything reported in the error console?
> 
> nothing at all

Confirmed, no error messages here either.
(Assignee)

Comment 8

9 years ago
Created attachment 443972 [details] [diff] [review]
patch v1.0

Hm looks like we always forgot to cache the element, the new patch has made this old bug visible, cool.

MAno forgot to remove the old helper from PUIU, the new helper is in the views file.
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Attachment #443972 - Flags: review?(dietrich)
(Assignee)

Updated

9 years ago
Summary: Live Bookmark update stuck in 'loading...' → Live Bookmark status menuitem persists in menus
Attachment #443972 - Flags: review?(dietrich) → review+
This appears to be fixed using the latest hourly build. 

cset: http://hg.mozilla.org/mozilla-central/rev/771e928c4a16

Mozilla/5.0 (Windows; U; Windows NT 6.1; WOW64; en-US; rv:1.9.3a5pre) Gecko/20100506 Minefield/3.7a5pre ID:20100506164339

Not going to close because I wonder if there more followup, as to why it was not closed at check-in.
Duplicate of this bug: 564356
(Assignee)

Comment 11

9 years ago
I just asked Mossop to push for me

http://hg.mozilla.org/mozilla-central/rev/386cd7683b91
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a5
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100506 Minefield/3.7a5pre ID:20100506164339

Verified
Status: RESOLVED → VERIFIED
(Assignee)

Comment 15

9 years ago
not sure what you mean, if a feed fail to load the message will say it. This bug is about having more than one identical messages (so 2 or more "live bookmark loading" or 2 or more "feed failed to load" entries in the same menu). Also, you did not post your user agent.

Comment 16

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100507 Minefield/3.7a5pre Firefox/3.6 ID:20100507131745

Sorry for forgetting the UA.

I get one failed message which does not disappear after reloading. But i guess Minefield is right here:
Error: junk after document element
Source file: http://feeds.howstuffworks.com/DailyStuff
Line: 57, Column: 7
Source code:
</rss>a

Unless there is something wrong with that i leave it here.
(Assignee)

Comment 17

9 years ago
the fact it doesn't disappear is expected, since I must be able to know that at any moment I could open the feed menu, and it could update while i'm not looking at it.
You need to log in before you can comment on or make changes to this bug.