100% CPU load and system unresponsive during the sending of an e-mail with attachment with STARTLS/SSL enabled

RESOLVED DUPLICATE of bug 538283

Status

--
major
RESOLVED DUPLICATE of bug 538283
8 years ago
8 years ago

People

(Reporter: milos.biba, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.1.249.1064 Safari/532.5
Build Identifier: SP2

We are using secured IMAP4 in all of our computers in the company. All users have this problem: every time they try to send the e-mail with attachment, the computers are unable to operate anything else than sending it. The CPU usage is at 100% with high priority during the sending and also during copying to the sent folder. This is only STARTTLS/SSL issue. Sending mails with attachments without encryption is without problems.

Reproducible: Always

Steps to Reproduce:
1.enable STARTLS or SSL/TLS encryption in the smtp server settings
2.try to send any mail with any attachment
3 [review].sit down and wait a couple of minutes and listen the cpu fan speed increasing while the CPU becomes hotter and hotter. It is impossible to do some multitasking till the sending process is finished at all.
Actual Results:  
CPU is hogged by sending the e-mail... and is not free for any other operation...

Expected Results:  
Sending of the e-mail securely without that massive CPU usage. This is usual in all other e-mail clients. No clients need to use that big amount of CPU time. Something is wrong

Affected versions: Every version 3.x.x including newest 3.1 beta 2... Version 2 is OK without this bug
(Reporter)

Comment 1

8 years ago
No antivirus is running. No third party antispam is running, only windows XP firewall is running. So no other software could do this strange behaviour...

No matter if you use the imported profile from version 2 or a brand new profile, in both these cases the bug is actual. Turning off the global indexing also doesn't solve this problem.

Sending unencrypted mail is not possible in our company, so this is not the solution for us.

Our computers (30)are couple of years older machines with CPU like celeron (prescott) 2-3 GHz or amd athlon 64 - 2 GHz with 512-1024 ram and windows XP sp2. I think this computers are strong enough for the using of e-mail.
(Reporter)

Updated

8 years ago
Component: General → Message Compose Window
(Reporter)

Updated

8 years ago
(Reporter)

Updated

8 years ago
Version: unspecified → 3.0

Comment 2

8 years ago
do you see this problem when started in safe mode?  And when the attachment is very small, like a few bytes?
https://support.mozillamessaging.com/en-US/kb/Safe+Mode 

removing P1 and sec-sensitive
Group: core-security
CC list accessible: false
Component: Message Compose Window → Networking: SMTP
Priority: P1 → --
Product: Thunderbird → MailNews Core
QA Contact: general → networking.smtp
Not accessible to reporter
Summary: 100% CPU load and system unresponsible during the sending of an e-mail with attachement with STARTLS/SSL enabled → 100% CPU load and system unresponsive during the sending of an e-mail with attachment with STARTLS/SSL enabled
Version: 3.0 → unspecified
(Reporter)

Comment 3

8 years ago
Yes, this bug is also present when running TB in the safe mode. Doesn't matter the attachments size and type. Every sending of an every attachment through secured smtp causes the 100% CPU usage in high priority.

Mbiba
Closing as DUP of Bug 538283. Please re-open if different problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 538283
You need to log in before you can comment on or make changes to this bug.