Update location bar to show Firefox, its favicon, and "Add-ons Manager"

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
RESOLVED WORKSFORME
8 years ago
3 months ago

People

(Reporter: whimboo, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rewrite], URL)

(Reporter)

Description

8 years ago
Regarding the design specs the following items are proposed for the location bar:

* The Firefox icon
* An orange identity panel
* "Add-ons Manager" shown up as url

This proposed changes would be result in a different behavior as all the other existing in-content pages show. We should have a design which is identical too all other pages, e.g. the troubleshooting page. Sure, those aren't used very often, but it's some-kind strange when the Add-ons Manager is using its own visual representation.

Comment 1

8 years ago
Wouldn't the add-ons puzzle piece icon be more appropriate?

Comment 2

8 years ago
(In reply to comment #1)
> Wouldn't the add-ons puzzle piece icon be more appropriate?

No, because this feature might be used for other things, like an integrated downloads manager, for example.

Comment 3

8 years ago
(In reply to comment #2)
> No, because this feature might be used for other things, like an integrated
> downloads manager, for example.

What do you mean by "this feature"? If you mean content loading in a tab, then surely each one would have the smarts to know what icon to load.

Regardless, if the Firefox icon is used, it should really be the application icon as this feature will be in other applications.

Comment 4

8 years ago
(In reply to comment #3)
> What do you mean by "this feature"? If you mean content loading in a tab, then
> surely each one would have the smarts to know what icon to load.

I'm referring to this:

(Quote from comment #0)
> * The Firefox icon
> * An orange identity panel
> * "Add-ons Manager" shown up as url
I'm not sure if that was a placeholder in the mockups or not. If not, this will need to be part of the theme redesign and the in-content redesign. And possibly the places breadcrumb-like navigation. And the same thing may need to be applied to all similar in-content pages too (eg, about:home).
Maybe I'm old-fashioned, but what I expect in the URL bar is the URL you would type to get there, i.e., "about:addons", not "Add-Ons Manager", which belongs in the Tools menu and on the addons manager's titlebar and tab, but IMHO not in the URL bar. Similarly, the contents of an HTML page's <title> element belongs on the browser window's titlebar (for the current tab) or that page's tab, but IMHO not in the URL bar.

Do we really want to make users unlearn (more than they already do) what a URL is and what it is for?
The current plan is that this won't be visible at all.
Keywords: uiwanted
Duplicate of this bug: 576727

Comment 9

5 years ago
I guess this should be closed per comment #7 and bug 571970 FIXED status.  Unless it can be used to accept the resulting requests.

Comment 10

3 months ago
I think this is as fixed as it is going to be. If we want to display non-URL things in the address bar, we would have to make slightly bigger changes, but the favicon and "Firefox" wordmark are there.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.