Last Comment Bug 564422 - Access to getfirebug.com/wiki
: Access to getfirebug.com/wiki
Status: RESOLVED FIXED
:
Product: mozilla.org Graveyard
Classification: Graveyard
Component: Server Operations (show other bugs)
: other
: All All
: -- normal (vote)
: ---
Assigned To: Shyam Mani [:fox2mike]
: matthew zeier [:mrz]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-07 07:13 PDT by John J. Barton
Modified: 2015-03-12 08:17 PDT (History)
3 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description John J. Barton 2010-05-07 07:13:07 PDT
Most of getfirebug.com is served from SVN content under https://svn.mozilla.org/projects/getfirebug.com/. But there is no /wiki and I can't find the files that control the mediawiki instance. We'd like to tweek some of the CSS.
Comment 1 John J. Barton 2010-05-23 20:34:35 PDT
Reed, sorry but I think this is in the wrong bin and I don't know where it should be. Can you repoint it?
Comment 2 Reed Loden [:reed] (use needinfo?) 2010-05-23 20:42:28 PDT
(In reply to comment #1)
> Reed, sorry but I think this is in the wrong bin and I don't know where it
> should be. Can you repoint it?

Done. :)
Comment 3 John J. Barton 2010-05-23 20:48:35 PDT
thanks! server-ops, server-ops, got to remember these go in server-ops...
Comment 4 Shyam Mani [:fox2mike] 2010-05-23 20:58:42 PDT
Well, the wiki was installed by us, so it just sits on our servers for now. It's a standard mediawiki install :

[root@mradm02 wiki]# svn info
Path: .
URL: http://svn.wikimedia.org/svnroot/mediawiki/branches/REL1_15/phase3

So you should be able to modify what you need and we could patch it?
Comment 5 Shyam Mani [:fox2mike] 2010-05-23 21:05:29 PDT
Also, you don't need access to modify CSS.

http://www.mediawiki.org/wiki/Manual:CSS

For example, 

https://wiki.mozilla.org/MediaWiki:Cavendish.css
Comment 6 Shyam Mani [:fox2mike] 2010-05-23 21:06:19 PDT
(In reply to comment #5)
> Also, you don't need access to modify CSS.

I meant access in terms of to the wiki code. You'll need to be an admin though.
Comment 7 John J. Barton 2010-05-23 21:24:57 PDT
(In reply to comment #5)
> Also, you don't need access to modify CSS.
> 
> http://www.mediawiki.org/wiki/Manual:CSS

Thanks, but this page refers to Common.css which has no content on our site. For example we'd like to update the firebug to the new Fiery Firebug: where is it defined?

> 
> For example, 
> 
> https://wiki.mozilla.org/MediaWiki:Cavendish.css

I don't understand how this page relates to our wiki.
Comment 8 Shyam Mani [:fox2mike] 2010-05-23 21:33:06 PDT
(In reply to comment #7)
> Thanks, but this page refers to Common.css which has no content on our site.
> For example we'd like to update the firebug to the new Fiery Firebug: where is
> it defined?

http://www.mediawiki.org/wiki/Manual:FAQ#How_do_I_edit_the_wiki.27s_CSS.3F
 
> I don't understand how this page relates to our wiki.

It was a live example to show you how these kind of edits work.
Comment 9 John J. Barton 2010-05-23 21:46:49 PDT
Ok, according to
http://www.mediawiki.org/wiki/Manual:FAQ#How_do_I_change_the_logo.3F
I need to modify LocalSettings.php 

>The logo that appears in the top left of each page is determined by the $wgLogo >configuration line in the LocalSettings.php file.
Comment 10 Shyam Mani [:fox2mike] 2010-05-23 22:14:44 PDT
We'd have to do that for you, since that contains the DB settings etc.

What do you need it changed to? The current value is :

#Custom config - Bug #513911
$wgLogo = 'http://getfirebug.com/images/firebug-logo.png';
Comment 11 John J. Barton 2010-05-24 07:38:04 PDT
Please set it to
$wgLogo = "{$wgScriptPath}/Wiki-logo-top-left.png"; 

That points into our wiki file space so we can change it in future.
Comment 12 Shyam Mani [:fox2mike] 2010-05-24 09:07:40 PDT
Do you have an image there? When I make this change, it'll go live..so unless you have an image, it won't be visible. Thought I'd check before I made the change.
Comment 13 John J. Barton 2010-05-24 09:11:14 PDT
Yes, but of course I can only guess that {$wgScriptPath} will resolve as the Help docs claim.
http://getfirebug.com/wiki/index.php/File:Wiki-logo-top-left.png
http://getfirebug.com/wiki/images/8/84/Wiki-logo-top-left.png
Comment 14 John J. Barton 2010-06-07 15:26:50 PDT
How can we make progress?
Comment 15 Shyam Mani [:fox2mike] 2010-06-07 23:58:59 PDT
config updated and pushed out.
Comment 16 John J. Barton 2010-06-08 20:17:21 PDT
Unfortunately this fix did not work. 

From my perspective the wiki is 'broken'. Operations on the page:
http://getfirebug.com/wiki/index.php/File:Wiki-logo-top-left.png
do not result in reasonable outcomes. Uploads don't take effect, the page says the current version is two different images. And the logo-top-left remains the old value.
Comment 17 Shyam Mani [:fox2mike] 2010-06-08 22:15:00 PDT
This was the cause :

trinity:~ shyam$ curl -L -I http://getfirebug.com/wiki/images/8/84/Wiki-logo-top-left.png
HTTP/1.1 200 OK
Date: Wed, 09 Jun 2010 05:12:26 GMT
Server: Apache
Accept-Ranges: bytes
Content-Length: 23713
Cache-Control: max-age=2592000, public
Expires: Fri, 09 Jul 2010 05:12:26 GMT
Content-Type: image/png
Connection: Keep-Alive

So the image was cached, and hence you didn't see the update. I flushed the cache and it's fine now.
Comment 18 John J. Barton 2010-06-09 08:00:03 PDT
The image is loading correctly now. Thanks!

How can we accomplish this in future? Working on the wiki is very confusing when you can't determine if a fix is successful or not.

Note You need to log in before you can comment on or make changes to this bug.