Closed Bug 564507 Opened 13 years ago Closed 13 years ago

Start Page 'open all tabs' is buggy

Categories

(Firefox for Android Graveyard :: General, defect)

x86
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: martijn.martijn, Assigned: mfinkle)

References

()

Details

(Whiteboard: rc1.1)

Attachments

(1 file)

To reproduce:
- Go to http://translate.google.com
- Type the letter 't' in the textarea
- Close Fennec and restart
- On restart, click on "Google Translate" from "Your tabs from last time"

Expected result:
One tab with the url from last time should be opened, which should be: http://translate.google.com/#auto|en|t

Actual result:
3 (!) tabs are opened. 
The first tab has this url: http://translate.google.com/#auto
The second tab has this url: jar:file:///C:/Users/mw22/Desktop/moz/fennec_builds/fennec193_20100506/chrome/chrome.jar!/content/en
The third tab has this url: jar:file:///C:/Users/mw22/Desktop/moz/fennec_builds/fennec193_20100506/chrome/chrome.jar!/content/t

This is tested on a fennec windows, using a 1.9.3 trunk build, but the equally weird thing happens on the 1.9.2 branch of fennec on the n900 device (the urls are somewhat different for obvious reasons).
We should take a look at this to find what's happening. Not necessarily saying it's a blocker, but I'd like to know what's happening.
tracking-fennec: --- → ?
Whiteboard: rc1.1
This happens because we bundle all the URLs into a single "|" delimited string and then split the string:

http://mxr.mozilla.org/mobile-browser/source/chrome/content/aboutHome.xhtml#143

We should just try to pass an array for multiple tabs
Summary: Session restore is buggy on translate.google.com → Start Page 'open all tabs' is buggy
Attached patch patchSplinter Review
This patch just makes openTabs take an array. We now open a single tabOK and open all tabs OK, even if the URL has a "|" in it!
Assignee: nobody → mark.finkle
Attachment #446004 - Flags: review?(21)
pretty safe, low-risk patch
Comment on attachment 446004 [details] [diff] [review]
patch

Setting the test url as the start pahe of Firefox also opens 3 tabs. I'll see if there a bug open for that.
Attachment #446004 - Flags: review?(21) → review+
pushed to m-b:
http://hg.mozilla.org/mobile-browser/rev/a8f1ad66903e

pushed to m-1.1:
http://hg.mozilla.org/releases/mobile-1.1/rev/b2b24cb0de83
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
verified FIXED on builds:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2.5pre) Gecko/20100519 Namoroka/3.6.5pre Fennec/1.1b2pre

and

Mozilla/5.0 (X11; U; Linux armv71; Nokia N900; en-US; rv:1.9.3a5pre) Gecko/20100519 Namoroka/3.7a5pre Fennec/2.0a1pre
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.