Google Calendar Read Only

VERIFIED INVALID

Status

Calendar
Lightning Only
--
major
VERIFIED INVALID
8 years ago
8 years ago

People

(Reporter: Chris, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0)
Build Identifier: Lightning 1.01 beta1

Google calendar is read only no matter how many times I uncheck it in the properties menu.  This does not happen under Sunbird.  I get a "modification failed" error on the calendar.  Lightning loads google calendar (from the private url) no problem.

Reproducible: Always

Steps to Reproduce:
1.Load calendar 
2.  Attempt to modify a calendar event
3.

Comment 1

8 years ago
Usually remove and re-add the calendar works for me (since this is a remote calendar, this causes no data-loss), when this happens. Don't know what the cause is.
Please enable calendar.debug.log and calendar.debug.log.verbose in the advanced config editor (Options > Advanced > General > Config Editor) and check your error console for messages.
(Reporter)

Comment 3

8 years ago
calICSCalendar channel.requestSucceeded: false

Warning: There has been an error reading data for calendar: Home. It has been placed in read-only mode, since changes to this calendar will likely result in data-loss.  You may change this setting by choosing 'Edit Calendar'. Error code: DAV_PUT_ERROR. Description: Publishing the calendar file failed
Status code: 0

Error: An error occurred when writing to the calendar The Campanella! Error code: MODIFICATION_FAILED. Description: 
Source File: file:///C:/Users/Chris/AppData/Roaming/Thunderbird/Profiles/yhwks4wk.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Users/Chris/AppData/Roaming/Thunderbird/Profiles/yhwks4wk.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCalendarManager.js
Line: 1000

Comment 4

8 years ago
(In reply to comment #3)

This explains everything. The iCal feed provided by Google is always read-only. Google doesn't allow changes to the calendar using the iCal feed. Lightning can't do anything here.

To get write access to your Google Calendar use the CalDAV protocol as described on <http://www.google.com/support/calendar/bin/answer.py?answer=99355> (follow the Sunbird steps).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.