Blank page favicon pulled from cache when added to bookmarks toolbar

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: parktheredcar, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729)

When I open a new tab and drag it to the bookmarks toolbar, the default icon used appears to be pulled from a cache somewhere. Instead of the icon of a blank piece of paper, A seeemingly random icon from a site I have not visited in a few days shows up next to the newly created bookmark. The icon that is used does not necessarily match up with any bookmarks I have saved.

Additionally, I have Firefox set to clear my cache when it is closed. Do favicons not fall under this setting? I'm not sure if that's intentional or not.



Reproducible: Sometimes

Steps to Reproduce:
1. Open a new blank tab
2. Drag said tab to the bookmarks toolbar
3. Observe the new bookmark's icon.

This apparently doesn't work for everybody
Actual Results:  
Random icon from cached favicons is used.

Expected Results:  
Blank page icon should be used.

Windows XP SP3, Firefox 3.6.3

Comment 1

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.5pre) Gecko/20100523 Namoroka/3.6.5pre
It works for me. Tried 5 to 6 times, it uses a blank page icon. Try creating a new profile and see if you are able to reproduce. 
http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile.
(Reporter)

Comment 2

8 years ago
Unable to reproduce using a fresh profile. Switching back to my normal one, I'm still getting that issue. I'll try and figure it out what causes the icon to change, maybe that will shed some light on the situation.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729)

Comment 3

8 years ago
are you sure this is not caused by an add-on?
Please try to reproduce in Safe mode: http://support.mozilla.com/kb/Safe+Mode to check if any extension is causing the said problem.
(Reporter)

Comment 4

8 years ago
Reproduced in safe mode. Icon is still the same as it was when I last posted (Gmail icon).

Updated

8 years ago
Version: unspecified → 3.6 Branch
Sounds like some sort of database corruption, maybe caused by an external software or an add-on, if you don't care much about history data, ensure Firefox is closed, open the profile folder and rename places.sqlite to places.sqlite.backup then start firefox. That will reimport your bookmarks and clear any bogus favicon data, but as said history data will be lost.

Comment 6

7 years ago
Reporter -> Is this still an issue with Firefox 9? Did you do the steps in comment 5?
(Reporter)

Comment 7

7 years ago
I don't have XP anymore but I haven't seen it since. I did not try Marcos suggestion.

Comment 8

7 years ago
Thanks for reporting back - I will close the bug and feel free to post back if the issue re-occurs...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.