Closed Bug 564659 Opened 10 years ago Closed 10 years ago

Stale region of tab when "Close Tab" button is missing

Categories

(Firefox :: Tabbed Browser, defect, trivial)

x86
Windows Vista
defect
Not set
trivial

Tracking

()

RESOLVED DUPLICATE of bug 522392

People

(Reporter: picaune, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729)

When only one window is open, and it has only one tab, and the tab widget's contents (the title of the page) changes, either via navigation or via script, then the tab repaints most of itself, but not the part under where the close button would be if it's not visible. That part instead repaints whenever the tab widget itself receives focus or is moused over.

When there is more than one tab in a window, the close button is painted, so the problem either does not exist or wouldn't be noticed. When there is more than one window open, the problem appears to go away. It's only visible if there's exactly one browser window open, with exactly one tab.

Reproducible: Always

Steps to Reproduce:
1. Launch Firefox, with only one homepage set.
2. Navigate to a page with a long name (e.g. anything from the default "Latest Headlines" Live Bookmark
3. Move your mouse over the tab in the tab bar.
4. Navigate to another page with a long name.
Actual Results:  
After step 2, the tab paints most of the really long title, but stops short of the right side, sometimes cutting off in the middle of a letter.
After step 3, the tab looks normal again.
After step 4, most of the tab updates to the new title; however, a square on the right side still contains the last letter or few of the old title, possibly with an ellipsis -- however the title was displayed there from the last page.

Expected Results:  
Steps 2 and 4 should paint the text in the entire tab.
Step 3 should have no effect on the tab, at least under Strata.

My configuration has browser.tabs.autoHide set to false (Tab bar is always visible) and browser.tabs.closeButtons set to 1 (Firefox 2.0 behavior, each tab gets a close button -- although not when there's only one tab; new behavior introduced in 3.5 apparently), which are both defaults.

I've seen this occur on 3.5.9 and 3.6.3, on Windows XP, Windows Vista, and Windows 7, using x86 builds on x86 and x86_64 OSes. In all cases I was using the default Strata Winstripe theme.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 522392
You need to log in before you can comment on or make changes to this bug.