New AM: Dictionaries should be moved to "languages" or get their own tab

VERIFIED DUPLICATE of bug 338074

Status

()

enhancement
VERIFIED DUPLICATE of bug 338074
9 years ago
8 years ago

People

(Reporter: lkzpj456, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rewrite])

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 FireTorrent/2.0.1 (.NET CLR 3.5.30729)
Build Identifier: 

Because the Add-ons manager gets a redesign, I wanna suggest, that all installed dictionaries should be listed in "languages" or should get their own tab: "dictionaries". Because they aren't extensions as such and aren't listed as those on the add-ons website. But besides the sense of this change, it would also let the manager appear more tidy and neat.

Reproducible: Always
Needs some ux feedback.
Blocks: 550048
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: uiwanted
Whiteboard: [rewrite]
Version: unspecified → Trunk

Comment 2

9 years ago
I assumed that's what languages were for. I do hope they'll go there.
So the option is to either mix up dictionaries with locale packs or with extensions.

FWIW we don't have a way to detect that an extension provides a dictionary right now which means doing anything other than mixing them in with extension will require dictionaries to update themselves.

Comment 4

9 years ago
Wouldn't such an idea allow the separation of coding and language in extensions and thus even make it feasible for third-parties to release locales for extensions without relying on the original author? Also it could bring down the size of some extensions?
(In reply to comment #4)
> Wouldn't such an idea allow the separation of coding and language in extensions
> and thus even make it feasible for third-parties to release locales for
> extensions without relying on the original author? Also it could bring down the
> size of some extensions?

That is nothing to do with this bug. This bug is about where to display dictionaries in the add-ons manager.

Third-parties can already release locales for extensions without relying on the original author.
Reporter

Comment 6

9 years ago
(In reply to comment #3)
> FWIW we don't have a way to detect that an extension provides a dictionary
> right now which means doing anything other than mixing them in with extension
> will require dictionaries to update themselves.

But the dictionaries are already listed in "languages" (context menu) for the spelling checker, so why wouldn't it be possible for the add-ons manager, too?

Comment 7

9 years ago
(In reply to comment #5)
> (In reply to comment #4)
> > Wouldn't such an idea allow the separation of coding and language in extensions
> > and thus even make it feasible for third-parties to release locales for
> > extensions without relying on the original author? Also it could bring down the
> > size of some extensions?
> 
> That is nothing to do with this bug. This bug is about where to display
> dictionaries in the add-ons manager.
> 
> Third-parties can already release locales for extensions without relying on the
> original author.

Sorry, I was just thinking about the new possibilities of which such a decision
would enable and would as such, support such a decision to move dictionaries to
the languages section.
(In reply to comment #6)
> (In reply to comment #3)
> > FWIW we don't have a way to detect that an extension provides a dictionary
> > right now which means doing anything other than mixing them in with extension
> > will require dictionaries to update themselves.
> 
> But the dictionaries are already listed in "languages" (context menu) for the
> spelling checker, so why wouldn't it be possible for the add-ons manager, too?

The way things work right now is that an extension when installed may provide a dictionary for the spell checking service to use (in addition to doing anything else). To move these into the languages section we'd need to detect that (not impossible) and really answer the question of what to do if the extension is more than just a dictionary. The cleanest solution is the have dictionaries declare themselves as just that with a new add-on type.

Updated

9 years ago
Duplicate of this bug: 599000
Duplicate of this bug: 604881
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 338074
Status: RESOLVED → VERIFIED
Keywords: uiwanted
You need to log in before you can comment on or make changes to this bug.