bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Mail is spontaneously deleted while connecting over NX

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
critical
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Mike Robinson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9) Gecko/20100401 Ubuntu/9.10 (karmic) Firefox/3.5.9
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9) Gecko/20100317 Lightning/1.0b1

My host computer is kubuntu (versions 9.10 and upgraded to 10.04 and the problem still persists) running NX server 3.4.0-5 with Thunderbird 3.0.4 (however this problem was still there in previous versions as well).

When I connect over NX to my host computer and run Thunderbird, the currently viewed message seems to sometimes spontaneously disappear when reading it without even touching the keyboard or mouse and even after the NX session has been disconnected (disconnected not closed) and once the messages start to be deleted, they can keep going indefinitely switching to the next message and deleting it and so on, or sometimes it just deletes the currently viewed message and stops. The other day, I came back to my computer and restored an NX session that had been disconnected to find that over 1400 messages had been deleted from one of my folders. Fortunately they were all in the trash.

Reproducible: Sometimes

Steps to Reproduce:
One way I have been able to reproduce this bug is by clicking the delete button on the keyboard and then just leaving it. After about 1 minute, the first message disappears. I haven't been able to reproduce it where the messages continue to delete indefinitely, however it has happened 3-4 times over the past few months.

I have tried this on an account that has a separate inbox from the Local Folders and also on an IMAP account and both have the same effect. I also tried restarting Thunderbird and it still happens.
Waht is NX ?
(Reporter)

Comment 2

8 years ago
See http://www.nomachine.com and http://en.wikipedia.org/wiki/NX_technology for more information about what NX is
Micah anybody you know using nx ?

Comment 4

8 years ago
I looked for other NX bugs going back to the dawn of time and didn't find anything useful

Comment 5

8 years ago
(In reply to comment #3)
> Micah anybody you know using nx ?

No, sorry.  If I understand correctly though, any issue would be caused by NX incorrectly sending signals that aren't happening.  Perhaps some research with NX if there are any such reports.  I'm not sure where their site is though.
(Reporter)

Comment 6

8 years ago
Thank you for your time guys. I agree that it would seem like NX is sending signals that aren't happening, however Thunderbird appears to be the only program affected by it. In the many other programs I've used, I haven't noticed this sort of behavior.

Comment 7

8 years ago
(In reply to comment #6)
> Thank you for your time guys. I agree that it would seem like NX is sending
> signals that aren't happening, however Thunderbird appears to be the only
> program affected by it. In the many other programs I've used, I haven't noticed
> this sort of behavior.

Any other programs where the Delete key has a noticeable effect?

Comment 8

7 years ago
Mike does this still reproduce?
(Reporter)

Comment 9

7 years ago
Micah, sorry, I forgot to answer your question until now. Only Thunderbird was affected from this. I did a bit of editing using text editors where it definitely would have wreaked havoc, but that never happened.

Wayne, Due to this bug, I developed the habit of always clicking on the "Delete" button with my mouse instead of the delete key on my keyboard to avoid this from happening, which is what I have been doing basically since I posted this bug. I have since upgraded to Thunderbird 10.0.2 and NX server 3.5.0-4 and I tried to reproduce the bug just now and I was unable to do so. It would appear it has been somehow fixed. I'm marking this as resolved for now and if it happens again, I will reopen it. Thank you for your help.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.