-moz-user-select:none content is included in Selection.toString()

RESOLVED FIXED in mozilla1.9.3a5

Status

()

Core
Selection
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: mats, Assigned: mats)

Tracking

(Depends on: 1 bug, {testcase})

Trunk
mozilla1.9.3a5
testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
-moz-user-select:none content is included in Selection.toString().

We tried to fix this in bug 166235 but it caused the regression
that they we're also excluded from .innerHTML (bug 558726) so
we reversed that bit.  Using the nsIDocumentEncoder::SkipInvisibleContent
flag in the fix for bug 39098 it should be possible to fix this bug
(still including it in innerHTML).

STEPS TO REPRODUCE:
1. select the line
"Select this -moz-user-select:none text" in
https://bug39098.bugzilla.mozilla.org/attachment.cgi?id=408411

EXPECTED RESULTS
The Selection.toString() text box should say "Select this text"
(Assignee)

Comment 1

8 years ago
Created attachment 445844 [details] [diff] [review]
Patch rev. 1

Trivial fix.

I'm rewriting the test so that it uses documentViewer.copySelection()
and then retrieving what's on the clipboard (since it models the actual
user action more closely than using nsIDocumentEncoder directly).
Assignee: nobody → matspal
Attachment #445844 - Flags: review?(dbaron)
Attachment #445844 - Flags: review?(dbaron) → review+
Comment on attachment 445844 [details] [diff] [review]
Patch rev. 1

r=dbaron

Comment 3

8 years ago
Mark as checkin-needed so that the patch isn't forgotten.
(Assignee)

Comment 4

8 years ago
I'll land it in a minute, just waiting to see if bug 39098 sticks first...
(Assignee)

Updated

8 years ago
Depends on: 567362
(Assignee)

Comment 5

8 years ago
http://hg.mozilla.org/mozilla-central/rev/2e4105f85be9
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a5
You need to log in before you can comment on or make changes to this bug.