Addon buttons in toolbar do not appear with multiple Firefox windows

RESOLVED INVALID

Status

()

RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: ds332, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.3) Gecko/20100423 Ubuntu/10.04 (lucid) Firefox/3.6.3
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.3) Gecko/20100423 Ubuntu/10.04 (lucid) Firefox/3.6.3

I have a number of addon buttons (Download Helper, NoScript, Flashblock, Adblock, Tobutton) in my menu toolbar, but when I open additional Firefox windows they do not appear in those toolbars.

Reproducible: Always

Steps to Reproduce:
1. Open Firefox
2. Open additional Firefox window (either using File->New Window or by reopening Firefox)
3. Buttons do not appear in menu toolbar of new window, but are still in original window.
Actual Results:  
Firefox window opens normally, but buttons do not appear in menu toolbar of new window, but are still in original window.

Expected Results:  
Would expect to see same toolbar buttons in all windows. Statusbar buttons/icons appear in all windows as expected, even for the same addons as do not appear in the toolbar.

Addons installed: Adblock Plus 1.2, BetterPrivacy 1.47.4, BlockSite 0.7.1.1, BugMeNot 2.2, ChatZilla 0.9.86, Domain Details 2.6.5, DownloadHelper 4.7.3, Download Statusbar 0.9.6.8, FireFTP 1.0.7l, Flashblock 1.5.13, Ghostery 2.1.1, Image Zoom 0.4.4, NoScript 1.9.9.74, oldbar 1.2, Organize Status Bar 0.6.4, Popup Blocker Settings 0.2.1.5, RefControl 0.8.13, Tab Mix Plus 0.3.8.2, Torbutton 1.2.5, TrashMail.net 2.0.4, Ubuntu Firefox Modifications 0.9rc2, Update Nofifier 0.1.5.5, User Agent Switcher 0.7.2

Dual Boot machine with Windows XP using shared Firefox profile, but I have not checked this in Windows.
(Reporter)

Comment 1

9 years ago
This is apparently being caused by both Torbutton and Ubuntu Firefox Modifications addons, not together but separately. If both are disabled the problem disappears, but if either is enabled it occurs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.