Pass word reset broken with accounts on phx-auth

VERIFIED WONTFIX

Status

VERIFIED WONTFIX
9 years ago
9 years ago

People

(Reporter: tracy, Assigned: telliott)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [weave1.3])

(Reporter)

Description

9 years ago
Seen with 1.3b5 using the new production server.

Tony asked me to file this one, He said it was working on stage yesterday.

0) Have an existing account with valid email address setup on https://phx-auth.services.mozilla.com
1) Set up a new profile and go through set up to access the existing account. except enter an incorrect password.
2) Click the Reset Password link.
3) In the resultant page, type the user name of the account in step 0. It should send you an email with a rest link.
4) Click the reset link in the email.

I'm not sure what's supposed to exactly happen at this point.  But right now you're taken to a page; https://auth.services.mozilla.com/weave-password-reset?<username>and<key>. That page is saying "Key does not match with username. Please request a new key"  

5) enter the user name a captcha phrase. 

Then you get a page: https://auth.services.mozilla.com/weave-password-reset with "We have no email address for your account and are unable to send a reset email"

I'd expect somewhere along the line there you're given a reset password.  


Is this bug because the auth server is being used for reset instead phx-auth server?
Flags: blocking-weave1.3?
(Assignee)

Comment 1

9 years ago
(In reply to comment #0)
 
> Is this bug because the auth server is being used for reset instead phx-auth
> server?

Yes. The phx server is configured for production launch, at which point it will be auth.services. For testing Zandr may need to reconfigure.
(Reporter)

Comment 2

9 years ago
reducing severity then,  if tony is happy with what he saw on stage testing.  we're probably good here.
Severity: critical → normal
Flags: blocking-weave1.3?
I'm going to suggest that you use entries in /etc/hosts, which will make all of this consistent, and save us having to reconfigure one more thing for launch.

add 

63.245.217.102        auth.services.mozilla.com

to your /etc/hosts to test.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
(Reporter)

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.