New addons manager doesn't see any of my extensions, themes, plugins, languages and search-plugins

VERIFIED DUPLICATE of bug 561600

Status

()

Toolkit
Add-ons Manager
--
critical
VERIFIED DUPLICATE of bug 561600
8 years ago
4 years ago

People

(Reporter: tonymec, Unassigned)

Tracking

({dataloss, regression})

Trunk
x86
Linux
dataloss, regression
Points:
---

Firefox Tracking Flags

(status1.9.1 unaffected)

Details

(Whiteboard: [rewrite])

Attachments

(4 attachments)

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a5pre) Gecko/20100511 SeaMonkey/2.1a2pre

This did not happen in yesterday's nightly (which called itself "SeaMonkey 2.1a1pre").

I'm using the same profile as yesterday (loading SeaMonkey with -P default).

None of my addons are functioning in this build, and the theme seems to be the default one. Even chatZilla, DOM Inspector and the Debug/QA UI are nowhere to be seen. But my userChrome.css customizations are still applied.

The addons manager has been redesigned (with tabs at left) (or is that due to my favourite theme being disregarded?) and whatever tab I select (Search Engines, Languages, Extensions, Themes or Plugins) the right pane always says "You don't have any add-ons of this type installed".

This is a show-stopper for me: I'm going back to yesterday's build until this bug is fixed.
Can you attach copies of extensions.log, extensions.sqlite and extensions.ini from your profile folder to this bug report.

http://support.mozilla.com/en-US/kb/Profiles
Whiteboard: [rewrite]
Created attachment 444712 [details]
extensions.ini

In reply to comment #1

Yes I can, but this is after reinstalling and restarting yesterday's nightly:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a5pre) Gecko/20100510 SeaMonkey/2.1a1pre - Build ID: 20100510003927
Created attachment 444716 [details]
extensions.log

There is no extensions.sqlite in this profile.
Created attachment 444719 [details]
extensions.rdf

...but there is an extensions.rdf
Created attachment 444727 [details]
My Config - Mozilla (default).html

You might also be interested in this list of addons in HTML as generated by the MR-Tech Toolkit extension.
(In reply to comment #3)
> Created an attachment (id=444716) [details]
> extensions.log
> 
> There is no extensions.sqlite in this profile.

If you run with one of the newer builds does one appear?
After I ran the latest nightly (see UA in comment #0) and came back to the one before that (see UA and Build ID in comment #2), should it have disappeared? BTW I did not search subdirectories of the profile directory nexrdon9.default
No it should not disappear, I'm quite surprised that one wasn't created by the newer build.
For a check, I closed down yesterday's nightly, reinstalled today's in a different directory, and started it with -P default: it is running now, and extensions.sqlite has not appeared.
If you could enable extensions.logging.enabled in about:config and then start Firefox from the command line and copy any messages it gives into this bug report then that would be very helpful.
I suppose these are unrelated, but: (1) between 2.1a1pre and 2.1a2pre I did not get the usual install-time popup saying that some of my extensions are incompatible with the new version, and (2) only the first 44 tabs of my 70-tab homepage appeared at 2.1a2pre startup.

In reply to comment #10: I don't use Firefox, but I can do it with SeaMonkey, wait a minute...
Very simple (but, I suppose, not very useful): with extensions.logging.enabled=true, the command

./seamonkey/seamonkey -P default 2>&1 |tee seamonkey.log

produces no output whatsoever, not even the usual two lines of "nsHeaderInfo: registerSelf called!"
Oh I forgot, Seamonkey won't be shipping the new code yet and won't work until it is.
Status: NEW → RESOLVED
blocking2.0: ? → ---
Last Resolved: 8 years ago
status2.0: ? → ---
Resolution: --- → DUPLICATE
Duplicate of bug: 561600
FWIW, your duplicate assignment seems to be right. :-(

In reply to comment #11 (1): extensions.lastAppVersion has been left at 2.1a1pre
Status: RESOLVED → VERIFIED

Updated

4 years ago
blocking-b2g: --- → 1.4?
blocking-b2g: 1.4? → ---
You need to log in before you can comment on or make changes to this bug.