Selecting a Charset in Composer disables Charset menu

VERIFIED FIXED in Future

Status

()

Core
Internationalization
P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: blee, Assigned: jbetak@netscape.com (away - not reading bugmail))

Tracking

({intl})

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed on the trunk)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Steps to repro:
1) Open a new blank page (Editor) from File menu.
2) Select a Character Coding menu (other than Auto-Detect) with no typing.
3) Check View| Character Coding menu.

==> All menu content is greyed out. According to nhotta, this greying out of 
menu is supposed to happen after a character input.

Observed in Win 10-13-09-MN6, Linux 10-12-08-MN6, and Mac 10-11-10-MN6
(Reporter)

Updated

18 years ago
QA Contact: teruko → blee

Comment 1

18 years ago
We do not have specs on this.  The related bug is 42837.
(Reporter)

Comment 2

18 years ago
A user should be able to change Charset freely before any text input is 
committed. With this problem, there's no way to do that without opening another 
blank page. This is an undesirable behavior. 

Updated

18 years ago
Status: NEW → ASSIGNED

Updated

18 years ago
Target Milestone: --- → M28

Comment 3

17 years ago
*** Bug 59938 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
The spec is spelled out in the Editor spec document.

Comment 5

17 years ago
There is an internal spec document which is newer than the external
spec document at:

http://mozilla.org/projects/intl/uidocs/editorcharmenu.html

But even in this older document, this issue is touched on in section

4. Changing Charset selection:

...
...

-----------------------
These 2 principles will cover the following sorts of specific cases:

Menu Enabled for reloading:

On  a new document meeting if there has been no input. (Same as "save in the
selected charset eventually" = Vacuous Reloading.) This is a fairly common
practice by the user.
----------------------------

I'll be happy to discuss details of Editor specs -- please
ask.

Comment 6

17 years ago
Please igore the word "meeting". It is a typo.

Comment 7

17 years ago
Reassign composer bug to yokoyama.
Assignee: nhotta → yokoyama
Status: ASSIGNED → NEW

Comment 8

17 years ago
Updating the target milestone.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9

Comment 9

17 years ago
teruko: is this a duplicate of 54770 ?

Comment 10

17 years ago
This is not dup of 54770.

This bug is that the character menu becomes disable without any typing after you
select one character coding. The bug 54470 is that the Character coding menu
becomes disable after typing some characters.   

Comment 11

17 years ago
> This bug is that the character menu becomes disable 
> without any typing after you select one character coding

Ths is a bug and needs to be fixed.

> The bug 54470 is that the Character coding menu
> becomes disable after typing some characters.

This is according to the spec we agreed on. (Unless this
occurs immediately after saving the document.)
Let's hope we did not change this behavior.

Updated

17 years ago
Target Milestone: mozilla0.9 → ---

Comment 12

17 years ago
Changing QA Contact to ylong.
QA Contact: blee → ylong

Comment 13

17 years ago
Roy - Please accept for M0.9.1

Adding intl and nsbeta1 keywords.
Keywords: intl, nsbeta1

Comment 14

17 years ago
Change QA contact to Marina.
QA Contact: ylong → marina

Updated

17 years ago
Target Milestone: --- → mozilla0.9.1

Comment 15

17 years ago
re-assigning QA contact
QA Contact: marina → ylong

Updated

17 years ago
Target Milestone: mozilla0.9.1 → Future

Comment 16

17 years ago
Marking as nsbeta1-
Keywords: nsbeta1 → nsbeta1-
roy,

I'm triaging bug 69911 and I'll take this one also, since they are all 
related...
QA Contact: ylong → jbetak

Comment 18

17 years ago
thanks
Assignee: yokoyama → jbetak
Status: ASSIGNED → NEW

Comment 19

17 years ago
Is this as designed. It doesn't soudn right to me.
accepting...
Status: NEW → ASSIGNED
while working on some other composer charset issues, I found what looks like a 
very easy fix. I'll try to get reviews for it along with the other composer 
patches this week...
cmanske: I have another minor change to editor.js, could you please have a look?

cc'ing ben and blake for xpfe sr.
Whiteboard: have fix, need r/sr

Comment 24

17 years ago
r=cmanske
cc'ing blizzard as i18n super-reviewer
Whiteboard: have fix, need r/sr → have fix, need sr
sr=blizzard
Changing whiteboard summary - thanks Chris! 
Whiteboard: have fix, need sr → ready to land, waiting for the tree to open
checked in - thanks everyone!
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Whiteboard: ready to land, waiting for the tree to open → fixed on the trunk

Comment 29

17 years ago
Fixed has been verified on 08-22 trunk build on all 3 platforms.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.