Mozilla either crashes or hangs Windows 7

RESOLVED INVALID

Status

()

Firefox
General
--
critical
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: Rajeev Arora, Unassigned)

Tracking

({crash, hang})

3.6 Branch
x86_64
Windows 7
crash, hang
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

Hi, I have found two instances where mozilla either crashes or hangs windows 7 (Home premium and Ultimate versions):
1. While browsing through emails in mail.yahoo and trying to go to jeevansathi.com from a link that is present in the email.
2. When one goes to "Forwarding and POP/IMAPI" setting under gmail settings and clicks the liink "Configure instruction" under POP Download.

I had to shut down my laptop by pressing the power butten for about 6 seconds.

Please provide a quick fix.

Thanks and regards,
Rajeev Arora

Reproducible: Sometimes

Steps to Reproduce:
Mentioned above.
Actual Results:  
I have to either shut down firefox (if it had crashed) through task manager, or hard shutdown the windows if in case it hangs.

Expected Results:  
Please fix the bug so that windows 7 does not hang
(Reporter)

Comment 1

8 years ago
I am currently using following addons:
1. Add blocker plus (ABP)
2. No Script
3. WOT
4. Ghostery

I hope this input helps.
Keywords: crash, hang
Version: unspecified → 3.6 Branch
Can you share with us one or more of the crash reports that were generated using your steps to reproduce:
http://support.mozilla.com/en-US/kb/Mozilla+Crash+Reporter#Viewing_crash_reports
Whiteboard: [sg:needinfo]
(Reporter)

Comment 3

8 years ago
Unable to create crash report as Windows 7 always hangs. However, I did find some files and directories in the mentioned crash folder, however, I do not know how to send it to you.

I have now installed Mozilla 3.6.4 beta inorder to get rid of the issue.
(Reporter)

Comment 4

8 years ago
The issue even figured out in Mozilla 3.6.4 beta.

When ever this issue occurs, the Windows 7 just hangs, I do not see the HDD LED lit or blink after the issue occurs. There is no response even for Ctrl+Alt+Del. I always have to hard shutdown the Windows and then start it in safe mode.
(Reporter)

Comment 5

8 years ago
(In reply to comment #2)
> Can you share with us one or more of the crash reports that were generated
> using your steps to reproduce:
> http://support.mozilla.com/en-US/kb/Mozilla+Crash+Reporter#Viewing_crash_reports

I have sent the crash report that existed in my PC to bsterne@mozilla.com.

Please note that comments 3 and 4 still remain true.
I am unable to create crash report as Windows hangs up. I will try to remove Adobe Flash player and then try to replicate the issue.
Please attach any crash-related information to the bug.  Sending me personal mail doesn't allow any of the other developers access to those materials.
(Reporter)

Comment 7

8 years ago
Created attachment 445155 [details]
Previous crash reports available with my PC

Previous crash reports
(Reporter)

Comment 8

8 years ago
I removed Adobe flash player and I am running Mozilla in Windows XP SP3 compatibility mode. Two hours have passed and I have not observed the bug.
(Reporter)

Comment 9

8 years ago
I had to reinstall Windows 7 to get rid of crashes. I will not install mozilla until I see a patch for this bug.
From your attachment:
bp-f47ea042-4ee6-48d2-8022-ec0522100511

Your crash report looks like a clear case of bug 527540.
Group: core-security
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Whiteboard: [sg:needinfo]
Duplicate of bug: 527540
That is not a dupe of the nvidia LSP bug.

The crash from the crash report is GrabXpcom.dll which is part of C:\Program Files\Orbitdownloader\addons\OneClickYouTubeDownloader\components\GrabXpcom.dll (from google).

A hanging Windows is always the fault of windows itself or in most cases from an installed driver. Firefox is a usermode application and it can never hang windows! Firefox can only trigger a bug in one driver and this driver running in the kernelmode can freeze windows. It would be Firefox fault (or one if it's installed addons/plugins) if Firefox itself only hangs. In that case you can kill the process in the task manager.

>I had to reinstall Windows 7 to get rid of crashes.
Yon don't have to do that for Firefox because it doesn't install any drivers or modifies something else on your system except the default browser integration.
Nothing runs from Firefox if you don't start it.

marking invalid.
Resolution: DUPLICATE → INVALID
You need to log in before you can comment on or make changes to this bug.