CairoImageOGL should initialize mTexture

RESOLVED DUPLICATE of bug 565875

Status

()

Core
Graphics
--
critical
RESOLVED DUPLICATE of bug 565875
8 years ago
8 years ago

People

(Reporter: timeless, Assigned: timeless)

Tracking

({coverity})

Trunk
coverity
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
124 class THEBES_API CairoImageOGL : public CairoImage
125 {
126 public:
127   CairoImageOGL(LayerManagerOGL *aManager)
128     : CairoImage(NULL)
129     , mManager(aManager)
130   { }
131   ~CairoImageOGL();
132 
133   virtual void SetData(const Data &aData);
134 
135   GLuint mTexture;


382 CairoImageOGL::~CairoImageOGL()
383 {
384   static_cast<LayerManagerOGL*>(mManager)->MakeCurrent();
385   if (mTexture) {
386     mManager->gl()->fDeleteTextures(1, &mTexture);
(Assignee)

Comment 1

8 years ago
Created attachment 444916 [details] [diff] [review]
patch
Assignee: nobody → timeless
Status: NEW → ASSIGNED
Attachment #444916 - Flags: review?(bas.schouten)
Attachment #444916 - Flags: review?(bas.schouten) → review+
(Assignee)

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 565875
You need to log in before you can comment on or make changes to this bug.