Service.startOver should purge client-specific data (i.e. client/tabs) from the server

RESOLVED FIXED in mozilla5

Status

Cloud Services
Firefox Sync: Backend
P1
normal
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: tracy, Assigned: philikon)

Tracking

unspecified
mozilla5
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [verfied in services])

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
Here's one I've seen for quite some time, but it wasn't until yesterday when auth server was locking me out that I got a hint what was triggering it. Once the auth server let me back in.  I synced the account I had been locked out of.  There were 15 identical tab sets from my XP client.  I investigated today and determined that "Use a Different Account" is somehow not properly cleaning up tab sets

STR:
0) Have two clients synced on the same Weave account, and have client A synced with a single tab open (for testing simplicity)
1) On client A, go to the Sync prefs > Manage Account and click "Use a Different Account"
2) Reset All Information, then Set Up Firefox Sync.
3) Choose "I'm already using Sync on another computer"
4) Enter Set up information for the account in use in step 0.
5) Merge this data with your sync data. Next, Next, Next, Finish
6) Allow sync on client A to complete.
7) then sync Client B, once it's complete check your tabs from other computers.

Tested results: 
Two identical tab sets from client A are present.  

Expected results:
One tab set from client A. Shouldn't step 2 be taking care this?

I had tried "Use a Different Account" many times on this test account.  I ended up with 15 identical tabs from my XP client and 10 from Win 7 client (checking from my Mac client)
Some engines have client-specific records (Clients/Tabs) that we should clean up.  We ultimately want some way of specifying TTL for these records, so idle clients go away, but in this case we should explicitly clean up after ourselves.
Summary: "Use a Different Account" creates another tab set from this computer → Service.startOver should purge client-specific data (i.e. client/tabs)
Target Milestone: --- → 2.0

Updated

8 years ago
Keywords: relnote

Updated

8 years ago
Duplicate of this bug: 565714

Updated

8 years ago
Duplicate of this bug: 568735

Comment 4

8 years ago
Created attachment 449997 [details]
duplicate tabs screenshot

attached a screenshot of what i see.  On weave 1.3.1

Updated

8 years ago
Blocks: 567273

Updated

8 years ago
Duplicate of this bug: 568735

Updated

8 years ago
Summary: Service.startOver should purge client-specific data (i.e. client/tabs) → Service.startOver should purge client-specific data (i.e. client/tabs) from the server

Updated

7 years ago
Component: Firefox Sync: UI → Firefox Sync: Backend
QA Contact: sync-ui → sync-backend
Target Milestone: 2.0 → 1.6

Updated

7 years ago
Priority: -- → P1

Updated

7 years ago
Depends on: 582662
(Assignee)

Updated

7 years ago
Duplicate of this bug: 563907
(Reporter)

Updated

7 years ago
Duplicate of this bug: 595747
Keywords: relnote
Whiteboard: [weave1.3]
Target Milestone: 1.6 → ---
(Assignee)

Updated

7 years ago
No longer depends on: 582662
Duplicate of this bug: 582662
Created attachment 524731 [details] [diff] [review]
v1
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #524731 - Flags: review?(rnewman)
Comment on attachment 524731 [details] [diff] [review]
v1

You can haz review.
Attachment #524731 - Flags: review?(rnewman) → review+
STR: Have two profiles connected to the same Sync account. Observe profile A's tabs on profile B in "Tabs From Other Computers". Now select "Deactivate this device" on profile A. Its tabs should now be gone from the "Tabs From Other Computers" page in profile B (may require restart of B).
(Reporter)

Comment 13

7 years ago
Nice. This one is helpful for QAing TFOC. Thanks for getting it.
Whiteboard: [fixed in services] → [verfied in services]
http://hg.mozilla.org/mozilla-central/rev/38a42892bc0b
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Target Milestone: --- → mozilla5
(Assignee)

Updated

7 years ago
Depends on: 662181
(Reporter)

Updated

6 years ago
Flags: in-litmus?
(Reporter)

Comment 15

5 years ago
removing in-litmus flag, it no longer exists
Flags: in-litmus?
You need to log in before you can comment on or make changes to this bug.