Closed Bug 565484 Opened 10 years ago Closed 10 years ago

Addons Manager is horizontally pannable with long extension titles listed

Categories

(Firefox for Android Graveyard :: General, defect)

Fennec 1.1
ARM
Maemo
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: aakashd, Assigned: mfinkle)

Details

(Whiteboard: rc1.1)

Attachments

(1 file)

Build Id:
Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2.5pre) Gecko/20100512 Namoroka/3.6.5pre Fennec/1.1b2pre

and

Mozilla/5.0 (X11; U; Linux armv71; Nokia N900; en-US; rv:1.9.3a5pre) Gecko/20100512 Namoroka/3.7a5pre Fennec/2.0a1pre

Steps to Reproduce:
1. Go to the Addons Manager
2. Type in "youtube" in the search field
3. After the results are populated, 

Actual Results:
You can horizontally pan the list because Shareaholic's title is too long

Expected Results:
You can't horizontally pan the list.
Whiteboard: rc1.1
Attached patch patchSplinter Review
<label>s need a width, or implicit width via flex, for crop= to work. This patch adds flex="1" to title labels. It also changes the <spacer flex="1000"/> so the version number stays aligned to the immediate right of the title.

The patch also removes crop= from addon-type labels that don't need crop anymore (the title gets cropped now)
Assignee: nobody → mark.finkle
Attachment #445044 - Flags: review?(mbrubeck)
To test this patch, search for "share" in add-on manager so the Shareaholic add-on is displayed. Then install it so you can see the result displayed in the installed add-ons too.
Ugh, Shareaholic uses a much smaller title when installed
Attachment #445044 - Flags: review?(mbrubeck) → review+
pushed m-b:
http://hg.mozilla.org/mobile-browser/rev/81961189db5a

needs to bake and needs approval for m-1.1
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Verified fixed on:
Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110922
Firefox/9.0a1 Fennec/9.0a1
Device: Samsung Galaxy S
OS: Android 2.2
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.