problem the searching news groups using more than 1 criteria

VERIFIED WONTFIX

Status

MailNews Core
Backend
P2
major
VERIFIED WONTFIX
19 years ago
10 years ago

People

(Reporter: Jim, Assigned: Phil Peterson)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
(This bug imported from BugSplat, Netscape's internal bugsystem.  It
was known there as bug #348069
http://scopus.netscape.com/bugsplat/show_bug.cgi?id=348069
Imported into Bugzilla on 04/28/99 15:31)

Using search window to search newsgroups, selecting more than one search
criteria causes erroneous result.

To reproduce:

Using Comm 4.5.1 Messanger window:

Select newsgroup netscape.public.mozilla.patches from the server
news.mozilla.org

With the various postings to this newsgroup displayed (in my case 904), select
[Search]from the EDIT pulldown menu.

* Match any of the following
[Subject] [contains] ---> patch

The result displays 199 matches

Then select the [More] button, and input:
[Subject] [contains] ---> for   (which should clearly apply to 1 of the many
the threads in this newsgroup)

The result displays 0 matches found

However, if I replace the first search word, and search only for the word "for",
I get 150 matches.

The result should (if I presume correctly) list either or both posted messages
that have the word "patch" and/or the word "for" included in the subject field.

Comment 1

19 years ago
assigning to sol for consideration in both 5.0 and (4.x)

Comment 2

19 years ago
TFV to 5.0

Updated

19 years ago
Assignee: sol → phil
Group: netscapeconfidential?
QA Contact: 4112

Comment 3

19 years ago
Per Phil, reassign to him.

Comment 4

19 years ago
FYI:  bugsplat #348069 is really a duplicate of #343617 (Logical OR doesn't work
with indexing enabled on server). I prefer my description of the problem, so
I'll paste it in here:

Using 4.5 and 4.51 on Win95
Using Netscape Collabra 3.5 server

Using logical OR in news message searching doesn't work if the server has
searching/indexing ON (extended search capable).

1.  News server has option for search/indexing ON.
    Newsgroups have messages and they have been indexed.
2.  Launch Messenger, subscribe to indexed newsgroup on said news server.
3.  Open newsgroup, download headers.
4.  Edit|Search Messages.
    Select subject newsgroup as the search scope.
    Search options set to search on specified server.
    You are in online state.
5.  Initiate a simple (sender/subject) search using "match any of the following"
utilizing more than one search criteria line which you know should yield a
match.
    Result:  No matches
6.  Change the radio button to "match all of the following".
    Initiate the same search.
    Result:  correct match(es) found.
7.  Go back to news server and disable searching/indexing option. (This requires
a server restart, so stop and restart the news server.)
8.  Repeat the news message search from step #5, using option to "match any of
the following".
    (You may have to unsubscribe and resubscribe to the server & groups because
it doesn't quickly recognize change/removal of extended search capabilities.)
    Result:  Now the OR search will work and yield appropriate matches.

Updated

19 years ago
Severity: enhancement → major
OS: Windows 95 → All
Priority: P4 → P2
Hardware: PC → All

Comment 5

19 years ago
Changing the platform, severity and priority to match what the bugsplat bug was
(343617).  This bug was P4, enh, Platform PC.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 6

19 years ago
I'm not sure if we're going to continue to support extended searching. I'll find
out. Marking assigned for now.

Updated

19 years ago
Target Milestone: M11

Comment 7

19 years ago
I think we decided not to support this, unless someone else does the work.
Moving to m11 for Phil to determine when he returns.

Comment 8

19 years ago
I don't think we will have search for PR1, so even if we do decide to fix this
bug, it does not need to happen by PR1
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 9

19 years ago
Extended search is cut for 5.0 since there isn't an NNTP standard for it, and
the standards process is not likely to produce anything soon. Marking wontfix.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 10

19 years ago
Perhaps we should turn this into a HELP WANTED bug.
(Assignee)

Comment 11

19 years ago
Since the protocol for extended search is stalled, and only Netscape News
Servers ever supported it, I don't think anyone would pick it up.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.