bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

"Unknown Error" when syncing

RESOLVED WORKSFORME

Status

Cloud Services
Firefox Sync: Backend
--
major
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Hmmwhatsthisdo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729) ID:20100401080539

When I attempt to sync Weave on Firefox 3.6, I get the "Unknown Error" popup, and the following shows up in the log:

Exception: deref(this) is undefined JS Stack trace: ()@util.js:267 < WeaveSvc__remoteSetup()@service.js:895 < ()@service.js:1187 < WrappedNotify()@util.js:114 < WrappedLock()@util.js:86 < WrappedCatch()@util.js:65 < sync()@service.js:1146 < (0)@sync.js:316




Reproducible: Always

Steps to Reproduce:
1. Log into Weave
2. Sync

Actual Results:  
"Unknown Error", no syncing

Expected Results:  
Syncing
What version of weave are you using?
(Reporter)

Comment 2

8 years ago
Current, I know that much, as there are no updates available. 1.2.3, isn't it?
Are you trying to log in with a username or an email address? You should be using a username.
(Reporter)

Comment 4

8 years ago
Nope. I'm using a username.
Can you post the full log as an attachment to the bug?
(Reporter)

Comment 6

8 years ago
Hmm. Seems to be fixed now. I'll post the log anyway.
(Reporter)

Comment 7

8 years ago
Created attachment 445562 [details]
Weave Verbose Log
This was the network issues last week.  Should be fixed now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.