No indication that found text is hidden

RESOLVED DUPLICATE of bug 407817

Status

()

Toolkit
Find Toolbar
--
enhancement
RESOLVED DUPLICATE of bug 407817
8 years ago
3 years ago

People

(Reporter: Jonathan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.2.3) Gecko/20100423 Ubuntu/10.04 (lucid) Firefox/3.6.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.2.3) Gecko/20100423 Ubuntu/10.04 (lucid) Firefox/3.6.3

A number of times now I have spent some time frustrated when the find feature reports that text is on a page, but I cannot spot it anywhere. One example I have just come across is on the stringsdirect home page, in which I was trying to find the link to buy cello strings. I searched for 'cello', which was reported as found, but it took me some time to realise that in order to actually find it I had to mouse over 'STRINGS' first, which opens a popup menu.

Of course this isn't a bug as such, but I certainly feel that this might be a source of frustration for less experienced users and stilts the fluency of the user interface. It has certainly caught me out a number of times.

Reproducible: Always

Steps to Reproduce:
1. Ctrl-F
2. Type search term
Actual Results:  
Find appears to have found text, (e.g. no red background to the edit box etc) but text is not visible so nothing is highlighted.

Expected Results:  
Some indication that text is found but not visible.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 305381

Comment 2

3 years ago
Bug 305381 is the exact opposite of this. It's about not finding what you can see on the page. For instance, the word “example” in something like <p>Ex<span style="display:none;">I'm invisible!</span>ample</p>

Bug 407817 is about finding words that you can't see on the page, and being unable to scroll to them with the Next/Previous buttons. For instance, <p style="overflow:hidden;width:1px;height:1px;position:absolute;top:-99999px;">Example</p>
Component: General → Find Toolbar
Product: Firefox → Toolkit
Duplicate of bug: 407817
You need to log in before you can comment on or make changes to this bug.