Multiple tabs records from the current client after canceling setup multiple times

RESOLVED DUPLICATE of bug 565430

Status

Cloud Services
Firefox Sync: Backend
RESOLVED DUPLICATE of bug 565430
8 years ago
8 years ago

People

(Reporter: Mardak, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Ragavan ran into this when testing out various setup paths by canceling. We do reset all prefs when canceling setup, but not entirely sure why we have multiple tab records.

But the logs show that multiple tab records are uploaded from the current client when it actually finishes sync. So perhaps somehow tab changes are stored locally in the tab tracker even when resetting stuff.
maybe Weave.Service.startOver() should nuke the stuff in <profile>/weave ?
(Reporter)

Comment 2

8 years ago
It would lose out on timestamps of changes that happened from before startOver. And that the code uses stuff in memory and not from disk after the service is running.

Comment 3

8 years ago
Created attachment 445188 [details]
Multiple copies of remote tabs

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 565430
You need to log in before you can comment on or make changes to this bug.