Last Comment Bug 565735 - Make XPCNativeWrappers wrap and unwrap all values passed across the membrane
: Make XPCNativeWrappers wrap and unwrap all values passed across the membrane
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Other Branch
: All All
: -- normal (vote)
: ---
Assigned To: Jason Orendorff [:jorendorff]
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on: 568671
Blocks: 563106
  Show dependency treegraph
 
Reported: 2010-05-13 13:04 PDT by Jason Orendorff [:jorendorff]
Modified: 2010-07-07 21:57 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Jason Orendorff [:jorendorff] 2010-05-13 13:04:07 PDT
So far XPCNWs haven't been terribly precise about this, because we're always calling into C++, which is going to unwrap everything anyway. Bug 563106 needs stronger guarantees which means being more precise.
Comment 1 Jason Orendorff [:jorendorff] 2010-05-27 00:49:27 PDT
Taking.
Comment 2 Jason Orendorff [:jorendorff] 2010-05-29 12:24:19 PDT
I think we plan to do this after bug 568671. Otherwise it's redundant work.

If that starts taking too long though I can do the redundant work, which isn't a whole lot, I think.
Comment 3 Jason Orendorff [:jorendorff] 2010-07-07 21:57:17 PDT
The XPCNativeWrapper re-implementation in js/src/xpconnect/wrappers takes care of this.  (It's called XrayWrapper<JSCrossCompartmentWrapper>.)

This is not exactly FIXED in the usual sense but I'm marking it RESO FIXED anyway because there's no point worrying further about it.

Note You need to log in before you can comment on or make changes to this bug.