initial start of TB: please redesign the options for pop account setup

RESOLVED DUPLICATE of bug 531088

Status

Thunderbird
Account Manager
--
major
RESOLVED DUPLICATE of bug 531088
8 years ago
4 years ago

People

(Reporter: macias, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Opera/9.80 (Windows NT 6.1; U; en) Presto/2.5.24 Version/10.53
Build Identifier: 

I have problem each time I install TB because its default options are too aggressive. The basic principle is, that with default options no damage should be done.

And TB has several points which leads to problem with unwanted data loss:
a) on first run TB forces user to create account
b) the account on default has such options turned on: automatic mail fetch, mail fetch on startup, removing mail from the server
c) the last option is hard to find

ad.c) with English version of TB it is all time hard for me to find it, because this option is simply burried down, with Polish language (I am Polish) I cannot find, period

ad.b) when you cancel the initial preferences dialog, the default options will be valid, and fetching will occur on spot, if you confirm them with auto fetch turned off the mail will be removed from the server anyway on accident mail fetch (manual)


I am not suggesting how to solve this, I am outlining the problem. TB does not let user to configure program from safe options to more "adventurous" _on demand_.

My preference is:
* put the option controlling deletion mail on fetch in more visible place -- maybe even next of options of fetching, they are very much related

* make more apparent what kind of deletion you are talking -- local deletion or deletion on server

* make the default options safe: no automatic fetching at all, no deleting mail on server at all

The last point is most important IMHO. 

( I am setting this report as bug, because it is bug in usability, in terms of coding it is rather a wish though ).

Reproducible: Always
Essentially, bug 231541 is the original "default POP settings cause dataloss" bug. The dependencies of the bug may address some of your points more specifically (one of them asks for a clearer explanation of what the `leave on server' preference really entails).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 231541
(Reporter)

Comment 2

8 years ago
Because of comment:
https://bugzilla.mozilla.org/show_bug.cgi?id=231541#c126

I am reopening this report. Everything I wrote above is still valid -- TB 3.0.4 (Polish version), Linux box. In short:
a) I am unable to locate the option "remove mail from server on fetch" (please note, I am not weekend-user)
b) the autofetch is on by default
c) TB forces user to create account on start
d) cancel & OK work against the user -- OK confirms the options (including not found, but unwanted), cancel cancels _changes_, so TB works with defaults (unwanted too)

And also please note: this report is not about single option, but "big picture" -- safe default options and letting user to run TB in his/her own pace, not in TB tempo.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

7 years ago
iirc there are several pop bugs about those issues.
might it be possible to consolidate?
Severity: normal → major
Summary: initial start of TB: please redesign the options → initial start of TB: please redesign the options for pop account setup
Whiteboard: dupeme

Comment 4

7 years ago
Checking default preferences in Thunderbird 6.0
Mozilla/5.0 (X11; Linux i686; rv:6.0) Gecko/20110812 Thunderbird/6.0
shows:

mail.server.default.leave_on_server;false
mail.server.default.num_days_to_leave_on_server;7

as the default. The same for SeaMonkey 2.3 (Final).

I'd have to agree with Maciej; the default should be set to 'true' in order to avoid the issue. Note: I have experienced the same problem on SeaMonkey when setting up a new SeaMonkey on user accounts.
similar to bug 531088

Comment 6

5 years ago
(In reply to Thomas D. from comment #5)
> similar to bug 531088

close enough to dupe?
Component: General → Account Manager
Flags: needinfo?(bluedzins)
(Reporter)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago5 years ago
Flags: needinfo?(bluedzins)
Resolution: --- → DUPLICATE
Duplicate of bug: 531088

Updated

4 years ago
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.