Download manager fails to clean up after disk full error

RESOLVED DUPLICATE of bug 471067

Status

()

RESOLVED DUPLICATE of bug 471067
8 years ago
8 years ago

People

(Reporter: ruizpeel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)

When downloading a file, after showing dialog with full disk error, nothing more happens. Status bar freezes up on the latest estimation. Download manager item freezes up with "unknown time" message and it can't be cancelled. The files however can be deleted (the right one and .part file). Also after cleaning disk and trying to download the same file, status bar tells about two files being currently downloaded (in one of two cases) or new download isn't showing in download manager (in the second case) first, then after closing and opening manager's window again, item is not updating (status bar is, however).

I'm not honestly sure if that happens always, it happened twice to me.

Reproducible: Always

Steps to Reproduce:
1. Start downloading a file bigger than the amount of free space on your HDD.
2. Wait for disk becoming full.
Actual Results:  
Download manager fails as descibed in summary.

Expected Results:  
Delete everything if it can't be resumed or ask user to free disk space.

Comment 1

8 years ago
Sounds similar to bug 471067

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 471067
You need to log in before you can comment on or make changes to this bug.