no "installation instructions"

RESOLVED DUPLICATE of bug 561481

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 561481
8 years ago
5 years ago

People

(Reporter: Felix Miata, Unassigned)

Tracking

3.6 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
As example http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.6.3/linux-i686/en-US/firefox-3.6.3.tar.bz2
includes README.txt and no other files that look like instructions for use.

README.txt, a mere 177 bytes, contains, in its entirety: "For information about installing, running and configuring Firefox including a list of known issues and troubleshooting information, refer to: http://getfirefox.com/releases/".

http://getfirefox.com/releases/ redirects to: http://www.mozilla.com/en-US/firefox/firefox.html?from=getfirefox

That URL contains no "installation instructions" that I can see. It does have "release notes" <http://www.mozilla.com/en-US/firefox/3.6.3/releasenotes/>, which has a list item "installing", but the entire text of that is: "Please note that installing Firefox 3.6 will overwrite your existing installation of Firefox. You won’t lose any of your bookmarks or browsing history, but some of your extensions and other add-ons might not work until updates for them are made available. You can reinstall an older version later if you wish to downgrade."

That seems to be a segment of installation instructions for a Windows version installer. So, this installation instruction path basically dead-ends.

As context for the above, the current openSUSE release, 11.2, contains 3.5.x. Its default repositories offer no option to upgrade to 3.6.x. So, someone flustered by the apparent inability to upgrade to the latest version via openSUSE package management is highly likely to gravitate eventually to http://www.mozilla.org/ for a solution, see and click on http://www.firefox.com/, be redirected to http://www.firefox.com/en-US/firefox/firefox.html and see and click on "free download" <http://www.mozilla.com/products/download.html?product=firefox-3.6.3&os=linux&lang=en-US> that triggers download and opens a "thanks for" page that contains neither the words "installation instructions" nor "installing", words that many of the less enlightened out in the real world fail to correlate to what may or may not be contained in "release notes".

Note that I know that simply extracting the bz2 and executing firefox is all that's required, but README.txt doesn't bother to say that, and neither does anything else in the above stated HOWTO path. Even http://support.mozilla.com/en-US/kb/Installing+Firefox just winds up looping back to the openSUSE package manager rather than explaining how to run the generic builds from http://releases.mozilla.org/pub/mozilla.org/firefox/releases/.

Comment 1

8 years ago
Looks like bug 358084
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> Looks like bug 358084

Pictures and great detail aren't actually required to deal with the current user vexation. "Installation" isn't actually required on Linux. Mere extraction is enough, which has already happened if the user is reading README.txt from his own extraction directory. All that's required is to know what to do, that is, run it. Another sentence or two in README.txt could easily do that, but it wouldn't hurt for the URL it contains to refer to something better than what it does now.
(Reporter)

Comment 3

8 years ago
Created attachment 445347 [details] [diff] [review]
proposed patch to README.txt
dupe of bug 561481

Comment 5

5 years ago
Installation instructions should be available from the download page itself, not only in the readme file.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 561481
You need to log in before you can comment on or make changes to this bug.