Memory leak 400 MB 1.5 GB when Firefox working more than 10 hours with lot of tabs

VERIFIED INCOMPLETE

Status

()

Firefox
General
VERIFIED INCOMPLETE
8 years ago
8 years ago

People

(Reporter: Alexander K, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
Build Identifier: Firefox/3.6.3

When I working with Firefox more than 10 hours with lot of tabs (usually I have more then 20) it starting to consume more and more memory, up to 2 GB. With every hour Firefox become slower. It looks like memory leak, because Firefox restart helps.

Reproducible: Always

Steps to Reproduce:
1. Open more than 20 tabs 2. Work actively more than 10 hours without restart 3. See, how slow it is and how many memory consumed
Actual Results:  
Firefox works very slowly

Expected Results:  
Firefox works fast as usual

Reproduced on different computers

Comment 1

8 years ago
Not enough data in the report to be useful. There's nothing a developer can do with this report. Even a list of URLs that are open in the tabs would not be enough, we would need all URLs that were visited in the entire 10-hour session. And that would be way too much data.

This doesn't mean that it isn't true, but there are dozens of similar reports. But there's nothing that makes this report better than the others. Sorry.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
only real thing is,create a new profile,update flash, java,reader, silverlight, etc, then test again
Hardware: All → x86
Version: unspecified → 3.6 Branch

Updated

8 years ago
Duplicate of this bug: 567071

Updated

8 years ago
Duplicate of this bug: 567337

Comment 5

8 years ago
Alexander / Anton / Kuliks / Zimovhenko : why do you keep filing the same report  over and over again, each time under a different name ?
Jo, bug 567347
Status: RESOLVED → VERIFIED

Updated

8 years ago
Duplicate of this bug: 567349
You need to log in before you can comment on or make changes to this bug.