Address completion drop-down box gives wrong behavior when clicked

VERIFIED DUPLICATE of bug 55179

Status

P3
minor
VERIFIED DUPLICATE of bug 55179
18 years ago
14 years ago

People

(Reporter: jason, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.14 i686; en-US; m18) Gecko/20001006
BuildID:    2000100722

when an address is typed in that starts matching two or more entries in the
history, a popup window appears listing the options. the arrow keys and enter
are capable of selecting between them, but clicking with the mouse closes the
popup without changing the entry.

Reproducible: Always
Steps to Reproduce:
enter a few addresses by hand that start the same.
try to type one in and select from the popup with the mouse.

Actual Results:  nothing.

Expected Results:  it should open the selected url.

Comment 1

18 years ago
Confirmed on Build ID 2000101220 Win32. Furthermore, the cursor, when over the
pop-up, should change to a hand, not stay a text cursor.
Note that it works fine with the keyboard, only the mouse is bugged.
Fabian.

Comment 2

18 years ago
I'm not seeing this on the latest Linux build..
Summary: address completion fails → Address completion drop-down box gives wrong behavior when clicked

Comment 3

18 years ago
confirming win98 2000101308

-->xp apps
Assignee: asa → don
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Apps
Ever confirmed: true
QA Contact: doronr → sairuh

Comment 4

18 years ago
I was just about to report this; reassigning to ducarroz but I'll look into 
it.  Is this behavior intentional (and if so, why)?
Assignee: don → ducarroz

Updated

18 years ago
Keywords: correctness
OS: Linux → All
Hardware: PC → All
(Assignee)

Comment 5

18 years ago

*** This bug has been marked as a duplicate of 55179 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
vrfy dup.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.