If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Some inline Images wouldn't been send in HTML-Mail multipart/related ( multipart/related[ text/html + image/jpeg ] )

RESOLVED DUPLICATE of bug 501298

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 501298
8 years ago
5 years ago

People

(Reporter: Sebastian Billau, Unassigned)

Tracking

(Blocks: 1 bug, {testcase})

x86
Windows XP
testcase

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.9) Gecko/20100317 Lightning/1.0b1 Thunderbird/3.0.4

When I try to send pictures in the mail as inline, it sometimes happens that they are not integrated in the mail.

Maildump without Header (The first picture isn't included in the mail :( ):
http://rapidshare.com/files/387573431/testmail.txt


Reproducible: Sometimes

Steps to Reproduce:
1. Insert Images to a HTML-Mail as inline
2. Send the mail
3. Receive the mail
4. Some images are missing
(Reporter)

Updated

8 years ago
Version: unspecified → 3.0
We also need the headers to properly analyse, could you use the add an attachment link to provide a complete example ?
(Reporter)

Comment 2

7 years ago
Ok, here is the complete example (From Send-Folder & Inbox-Folder)

The mail I had in myself shipping.

LINK: http://rapidshare.com/files/391779399/testmail.zip
Created attachment 447521 [details]
test mail inbox whatever that means ;-)

adding the unzipe eml file in bugzilla
Created attachment 447522 [details]
the sent version
Blocks: 505172
Keywords: testcase
Summary: Some inline Images wouldn't been send in HTML-Mail → Some inline Images wouldn't been send in HTML-Mail multipart/related
(Reporter)

Comment 5

7 years ago
The Send Version is a copy from Send-Folder in TB

After I had sent to myself, so it lands in the inbox ;)
So the two files are identical, and differ in the header (mailroute etc.)
(In reply to comment #5)

And, how can we see next phenomenon you stated in your comment #0?
> 4. Some images are missing

Apparently image data is integrated in the mail. Where can we see next problem you stated in your comment #0?
> it sometimes happens that they are not integrated in the mail.
Summary: Some inline Images wouldn't been send in HTML-Mail multipart/related → Some inline Images wouldn't been send in HTML-Mail multipart/related ( multipart/related[ text/html + image/jpeg ] )
Sebastian this might have been fixed by bug 351224. Could you take a few
minutes and download the latest nightly (
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-central/
), backup your profile and test and let us know if this is fixed or not ?

Comment 8

5 years ago
Testcase attachment 447521 [details] is case of
Bug 501298 TB fails to handle inline images of type <img src=URL1> if URL1 is redirected to URL2

First image in testcase is
http://www.abload.de/img/keindslelstalxonu.png
which is redirected to
http://h10.abload.de/img/keindslelstalxonu.png
Redirection causes bug 501298.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 501298
You need to log in before you can comment on or make changes to this bug.