Pressing disabled stop button kills picture loading

RESOLVED WORKSFORME

Status

()

Core
XUL
P3
normal
RESOLVED WORKSFORME
18 years ago
15 years ago

People

(Reporter: Jerry Baker, Assigned: Eric Vaughan)

Tracking

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

18 years ago
To reproduce:

1. Visit any URL and let it load completely.
2. Press the stop button (I know it's disabled, but it still stops animated 
GIFs).
3. Resize window.

Result: Pictures disappear. Going to other URL's all images are not loaded. 
Reload does not help.

Notes: Appears to only affect images located at the same domain as the page they 
are loaded from.

Comment 1

18 years ago
Reload button reloads image under Linux SuSE 6.3
and not all images are affected. Seems to be larger ones only.
(Reporter)

Comment 2

18 years ago
Updating URL field.

Do it at this URL. The ad banner will not disappear, but the images next to the 
articles will.

Comment 3

18 years ago
I was able to reproduce this behavior with M18 under winME at slashdot.org. 
However java.sun.com behaves correctly. Does the bug only trigger if an animated 
GIF is present on the page?

Comment 4

18 years ago
-> xpt, where a similar bug used to live
Assignee: pnunn → trudelle
Component: ImageLib → XP Toolkit/Widgets
QA Contact: tpreston → jrgm

Comment 5

18 years ago
->future
Target Milestone: --- → Future

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 6

17 years ago
I can't reproduce this, resolving as wfm.  If anyone still sees it, please
reopen with exact steps to repro, including the URL (cuz it ain't just any url).
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 7

17 years ago
reopening using the 200122904 nightly build on win2k.
Steps to reproduce:
1. Go to http://www.slashdot.org or resource:///res/samples/test2.html
2. Wait until the page loads enough so that the stop button becomes disabled.
3. Press the stop button.
4. Resize the window by clicking & dragging one of the 4 corners of the browser 
window.

I'm attaching before & after screenshots of both slashdot & the animation 
verification test showing this bug.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 8

17 years ago
Created attachment 21525 [details]
Slashdot before clicking the disabled stop button & resizing the browser window

Comment 9

17 years ago
Created attachment 21527 [details]
Slashdot after clicking the disabled stop button & resizing the browser window

Comment 10

17 years ago
Created attachment 21528 [details]
Animation verification test before clicking the disabled stop button & resizing the browser window

Comment 11

17 years ago
Created attachment 21529 [details]
Animation verification test after clicking the disabled stop button & resizing the browser window

Comment 12

17 years ago
I still can't reproduce this, perhaps it is Win2K-specific?  Not sure who should
own it.

Comment 13

17 years ago
See bug 49773; I'll fix the fact that clicking on the button when it's disabled 
does something shortly.  As for the picture loading, I'm nearly positive I saw 
a bug (and a fix) related to this very recently. I'll try to find it.

Comment 14

17 years ago
I can reproduce this on win2k, particularly with the animation demo, test2.html

I think this is bug 49222 [ignore the summary, and see comments by attinasi in 
body of the bug]. (Previously, the same could happen in chrome, but evaughan 
fixed that in bug 52663).

dup?

Updated

17 years ago
Assignee: trudelle → evaughan
Status: REOPENED → NEW

Comment 15

17 years ago
sounds dup-ish to me.  reassigning to evaughan, who said he had a fix for bug
49222 a while back.
(Reporter)

Comment 16

16 years ago
Mass removing self from CC list.
(Reporter)

Comment 17

16 years ago
Now I feel sumb because I have to add back. Sorry for the spam.

Comment 18

15 years ago
Can anybody still reproduce this?
Possibly related bugs (as bug 49222 and bug bug 49773) have been fixed ages ago
- more than two years. And this was last reproduced 30 months ago.
(Not to mention that I cannot reproduce it with Moz1.4 on Win2k.)

Comment 19

15 years ago
->WFM
(not seen anymore, related bugs fixed for years)
Status: NEW → RESOLVED
Last Resolved: 17 years ago15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.