If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

make in OBJDIR fails on Windows: msys-perl-wrapper (PERL) not found

RESOLVED WORKSFORME

Status

SeaMonkey
Build Config
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: InvisibleSmiley, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
NOTE: This probably affects TB, too, but I cannot tell (I'm not building TB).

Trying to build (make or make chrome) with MozillaBuild 1.4, VS 2005 and WinXP SP3 fails with the following error message if started in the OBJDIR:

/bin/sh: /c/mozilla-src/comm-central/build/msys-perl-wrapper: No such file or directory
make: *** [Makefile] Error 127

/c/mozilla-src/comm-central is my c-c checkout
/c/mozilla-src/seamonkey-central is my OBJDIR (PWD as of make call)

The problem source seems to be this line in $OBJDIR/config/autoconf.mk:

PERL        = /bin/sh /c/mozilla-src/comm-central/build/msys-perl-wrapper

This is clearly wrong since that doesn't exist. build/mozilla/msys-perl-wrapper exists, though.

Looking at /c/mozilla-src/comm-central/configure.in I found this line:

        PERL="/bin/sh ${MOZILLA_SRCDIR}/build/msys-perl-wrapper"

I guess MOZILLA_SRCDIR is wrong in this case for c-c. I don't know enough about build config to tell, though. Can someone please take over? I'll happily assist with testing of course.

I haven't check branch (2.0), only trunk.
(Reporter)

Comment 1

8 years ago
Sorry for the noise.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 566167
Jens,

actually this looks like a slightly different issue.

It actually seems like you forgot to reconfigure. Since, by using MOZILLA_SRCDIR you should have it expanded to |/c/mozilla-src/comm-central/mozilla/...| where you don't. Bug 566167 was merely the relative-path-to-configure-run case.

Please verify this situation. Either way it should all be fixed (if you ensure you re-run autoconf and re-run configure). Though this *is* a different Bug than what I just fixed.

The cause that exposed it to you was the same though, the 1_9_2 ifdef removals (as I dropped the c-c copy of the msys-perl-wrapper file).
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Depends on: 566167
(Reporter)

Comment 3

8 years ago
Well, no need to reconfigure. I'm always building from scratch.
Anyway, after the checkin for bug 566167 "make" in the OBJDIR works again -> closing.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.