Closed Bug 566519 Opened 11 years ago Closed 10 years ago

When updating and creating start menu entries on Windows, be less annoying

Categories

(Firefox :: Installer, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 598779

People

(Reporter: limi, Unassigned)

References

(Blocks 1 open bug)

Details

(Note: this is filed as part of the “Paper Cut” bugs — we assume that there may be multiple existing bugs on this. Please make them block this bug, and we will de-dupe if they are indeed exactly the same. Thanks!)

From the Reddit thread:

“you create about 8 startmenu shortcuts and put them all in a subfolder. i only want one. no subfolder.”

“You re-insert your icons and structure on update/upgrade. This should only happen on reinstall.”

Recommendations:
- Only insert a single item in the start menu (this requires us to have a better way to trigger Safe Mode, which is already a problem I think Faaborg has filed a bug on; we've seen people start in Safe Mode because they “want to be safe on the web” — this isn't an option that should be exposed for normal use)
- Don't change people's setup on upgrade, only restore the menu items when people restore.
Also, showing people a link to safe mode every time they access the program from the start menu undermines the user's impression of Firefox's quality.
Component: General → Installer
QA Contact: general → installer
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 598779
You need to log in before you can comment on or make changes to this bug.