Migrate /download/latest/* to zamboni

RESOLVED DUPLICATE of bug 591028

Status

P3
normal
RESOLVED DUPLICATE of bug 591028
9 years ago
3 years ago

People

(Reporter: clouserw, Unassigned)

Tracking

unspecified
4.x (triaged)

Details

(Reporter)

Description

9 years ago
We're getting a lot of broken add-on downloads these days, and I have no idea why, but since the page is up for migration anyway, I'd like to just get it on zamboni.  I don't see myself getting to this so I'm filing a much-hated nobody@ bug that we'll bump if we have to. :-/

The remora latest() code is in controllers/downloads_controller.php and is only about 25 lines so this shouldn't be too tough.  It does need tests though since we're dealing with platforms and type (jar vs xpi).  The function claims it supports: /downloads/latest/$id/$type/$platform/ URLs, but I grepped through a week of logs and never found type (I did find platform).  So we should see what is going on there.

Also, that URL is fugly, I think we should do something like /addon/$id/download/latest/ in zamboni.  Note that we need to have a "filename.ext" on the end of the URL like we do with remora.  We could 302 a prettier URL to the actual file download URL, but I'd want that to be pretty heavily cached, so I don't know if that would be a great idea.  Also, it would mean writing that function in zamboni too.
(Reporter)

Updated

9 years ago
Target Milestone: 5.11 → 5.12
(Reporter)

Updated

8 years ago
Target Milestone: 5.12 → 4.x (triaged)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 591028
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.