firefox does not follow $LANGUAGE

NEW
Unassigned

Status

()

Firefox
General
--
enhancement
8 years ago
4 years ago

People

(Reporter: Nicolò Chieffo, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; it; rv:1.9.2.3) Gecko/20100423 Ubuntu/10.04 (lucid) Firefox/3.6.3
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; it; rv:1.9.2.3) Gecko/20100423 Ubuntu/10.04 (lucid) Firefox/3.6.3

firefox starts using the language specified in $LANG instead of the ones specified in $LANGUAGE

Reproducible: Always

Steps to Reproduce:
1. set the LANGUAGE variable to "en"
2. set the LANG variable to "it_IT.uft-8" (or anything different)
3. start firefox
Actual Results:  
firefox is in Italian

Expected Results:  
Firefox should be in english

Comment 1

8 years ago
Why do you want to use $LANGUAGE ? $LANG is used to change the locale for libc.
(Reporter)

Comment 2

8 years ago
My distribution (ubuntu) uses $LANGUAGE and not $LANG

Comment 3

8 years ago
Firefox doesn't. $LANG is the standard in the C library.

Ubuntu seems to have set intl.locale.matchOS variable to true (default is false), and installed the extra langpacks. Otherwise $LANG isn't even used.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

8 years ago
I don't exactly know what you are saying because I'm not an expert of locales, but I'm reopening the bug because all apps follow the $LANGUAGE variable (nautilus, gedit, gnome-terminal, ecc.) and firefox is the only one which follows $LANG.

also read here: http://www.gnu.org/software/hello/manual/gettext/Locale-Environment-Variables.html#Locale-Environment-Variables
and here: http://www.gnu.org/software/hello/manual/gettext/The-LANGUAGE-variable.html#The-LANGUAGE-variable
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---

Updated

7 years ago
Version: unspecified → 3.6 Branch

Comment 5

5 years ago
Is this still an issue with current Firefox versions (23, 24, 25)?
Severity: normal → enhancement

Comment 6

5 years ago
See bug 419176 comment 3 for this bug being confirmed in 2008.

(In reply to Ioana Budnar, QA [:ioana] from comment #5)
> Is this still an issue with current Firefox versions (23, 24, 25)?

Yes.  On Fedora Core 19, Firefox 24 (standard distro package):

$ LC_ALL=en_US LANG=it_IT.utf-8 firefox # English UI
$ LANGUAGE=en_US LANG=it_IT.utf-8 firefox # Italian UI

The second should also be English UI.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86_64 → All
Version: 3.6 Branch → Trunk

Updated

5 years ago
Duplicate of this bug: 583793

Updated

5 years ago
Duplicate of this bug: 657103

Comment 9

4 years ago
I can confirm that this bug is still valid in Firefox 28. And curiously, the LANGUAGE variables *does* affect the UI language in Firefox, but in the wrong way; it actually *stops* the LANG variable working in some cases. Example:

I have LANG set to

nn_NO.UTF-8

and LANGUAGE set to

nn:no:nb:da:en_GB:en@quot

i.e., with Norwegian Nynorsk (nn) as my preferred language + some alternative language for applications that aren’t translated into Norwegian Nynorsk. When I start Firefox, I get the *English* UI, instead of the Norwegian Nynorsk UI, even though I *do* have the Norwegian Nynorsk language pack for Firefox installed.

If I instead completely remove the LANGUAGE environment variable, i.e., by typing

export LANGUAGE=

before starting Firefox, I *do* get the correct UI language, i.e. Norwegian Nynorsk. So it look like Firefox *tries* to handle the LANGUAGE variable, but it doesn’t handle it properly. The result is that Firefox always uses the English UI.
You need to log in before you can comment on or make changes to this bug.