Crash on beta.html5test.com [@ mozilla::WebGLContext::ValidateGL ]

RESOLVED FIXED

Status

()

RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: julroy67, Assigned: cjones)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; fr; rv:1.9.3a5pre) Gecko/20100518 Minefield/3.7a5pre
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; fr; rv:1.9.3a5pre) Gecko/20100518 Minefield/3.7a5pre

Firefox trunk crashes on beta.html5test.com with webGL enabled.

Reproducible: Always

Steps to Reproduce:
1.Go to about:config
2.Change webgl.enabled_for_all_sites to true
3.Browse to http://beta.html5test.com/
Actual Results:  
Crashes everytime : example http://crash-stats.mozilla.com/report/index/bp-2faefeeb-d91f-413d-9026-3f9732100518

Expected Results:  
Show up website with results

Tested with a new profile (no extensions, …)

CrashIDs :
- http://crash-stats.mozilla.com/report/index/bp-2faefeeb-d91f-413d-9026-3f9732100518
- http://crash-stats.mozilla.com/report/index/bp-03768b37-0f41-48c6-b9bf-5117e2100518
- http://crash-stats.mozilla.com/report/index/bp-422e7245-7237-4833-b487-264b12100518
To be more precise, I had to compile a custom Mesa due to lack of support for WebGL on my laptop (Intel GMA945).

So, compiled Mesa 7.8.1 with this configure:
CFLAGS=-DUSE_MGL_NAMESPACE ./configure --disable-glu --disable-glut --disable-egl --disable-glw --with-driver=osmesa

Then enabled webgl via about:config, by defining webgl.enabled_for_all_sites to true and webgl.osmesalib to /home/alex/tmp/mesa/Mesa-7.8.1/lib/libOSMesa.so

alex@portable-alex:~/tmp/mesa/Mesa-7.8.1$ file  /home/alex/tmp/mesa/Mesa-7.8.1/lib/libOSMesa.so
/home/alex/tmp/mesa/Mesa-7.8.1/lib/libOSMesa.so: symbolic link to `libOSMesa.so.7'
alex@portable-alex:~/tmp/mesa/Mesa-7.8.1$ file  /home/alex/tmp/mesa/Mesa-7.8.1/lib/libOSMesa.so.7.8.1 
/home/alex/tmp/mesa/Mesa-7.8.1/lib/libOSMesa.so.7.8.1: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, not stripped

alex@portable-alex:~/tmp/mesa/Mesa-7.8.1$ gcc --version
gcc (Ubuntu 4.4.3-4ubuntu5) 4.4.3
Copyright (C) 2009 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 446144 [details] [diff] [review]
Don't crash on failure to create a WebGL pbuffer
Assignee: nobody → jones.chris.g
Attachment #446144 - Flags: review?(vladimir)
Created attachment 446148 [details] [diff] [review]
Don't crash on failure to create a WebGL pbuffer, v2

With log message suggested by mattwoodrow.
Attachment #446144 - Attachment is obsolete: true
Attachment #446148 - Flags: review?(vladimir)
Attachment #446144 - Flags: review?(vladimir)
Comment on attachment 446148 [details] [diff] [review]
Don't crash on failure to create a WebGL pbuffer, v2

This shouldn't be necessary any more -- just checked in some code that adds support for OSMesa, and as part of it it errors out if gl remains null.
Cool. Will it be present in the nightly builds tomorrow ?
(Reporter)

Comment 7

9 years ago
Fixed in current nightly build, nice.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
I confirm it's fixed.

I'm unsure wether it's the correct place to ask, but is it normal that I can't use WebGL via OSmesa ?

Here is what I have in the console:
Canvas 3D: creating PBuffer...
Canvas 3D: can't get a native PBuffer, trying OSMesa...
Canvas 3D: can't create a OSMesa pseudo-PBuffer.

I have webgl.osmesalib set up to '/home/alex/tmp/mesa/Mesa-7.8.1/lib/libOSMesa.so', which is a version of Mesa compiled with USE_MGL_NAMESPACE.
You need to log in before you can comment on or make changes to this bug.