q['\xC7'] decompiled as q.\xC7 (illegal character)

RESOLVED DUPLICATE of bug 621814

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 621814
8 years ago
7 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

(Blocks: 1 bug, {testcase})

Trunk
x86
Mac OS X
testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
js> (function() { q['\xC7']; })
(function () {q.\xC7;})

js> (function () {q.\xC7;})
typein:2: SyntaxError: illegal character:
typein:2: (function () {q.\xC7;})
typein:2: ................^
After bug 621814, we get the valid identifier q.\u00C7 for this.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 621814

Updated

7 years ago
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.