New Tab Causes other tabs to disappear visually for small number of tabs

RESOLVED FIXED

Status

Firefox Graveyard
Panorama
P1
normal
RESOLVED FIXED
8 years ago
2 years ago

People

(Reporter: ozten, Assigned: iangilman)

Tracking

Details

(Whiteboard: tracked first-run)

(Reporter)

Description

8 years ago
Fx 3.6.4 on Ubuntu 9.10.

I had two windows open and installed TabCandy. After restart in a window with two tabs open, I did Cnt-T to open a new tab.

Expected:
A third tab would be created, I can see three tabs at the top of the browser chrome, and I could see all three the TabCandyscape view.

Actual:
One new tab, other tabs were gone. So I did Cnt-W to close the active tab, and I got back my two lost tabs... So visually the tabs were gone, but not actually.

So I did it again Cntl-T (same behavior) and clicked the "Spaces" icon. The TabCandyscape had 1 area with my two original tabs and no 3rd empty tab. There is a Untitled tab in the lower left (which is always there).

Opening a 2nd tab with Cntr-T again loses my two tabs and creates a series of (Untitled) tab headers once per Cntr-T. "Scrolling" Previous tab with Cnt-PgUp will get me back to the existing tabs.

Further testing... I guess this is the intended behavior. There is a "New tabs" group that is slurping up my ... wait for it ... new tabs.

Expected behavior: The traditional browser tabs shouldn't disappear until I manually group them in the TabCandy window. Existing tabs are in their own isolated groups. New tabs would follow this behavior, until I grouped them manually. The New tabs group is confusing, as I didn't create it and it doesn't really mean anything.
(Assignee)

Comment 1

8 years ago
Assigning to Aza for design.
Assignee: nobody → aza
Version: 0.3 → Trunk
Duplicate of this bug: 571903
bumping priority. i think this interaction is confusing/scary enough to prevent dogfooding.
Priority: -- → P1

Updated

8 years ago
Whiteboard: tracked first-run

Comment 4

8 years ago
This bug is solved by the closing of bug 575851.
Assignee: aza → ian
Status: NEW → ASSIGNED
Depends on: 575851

Comment 5

8 years ago
Mass moving all Tab Candy bugs from Mozilla Labs to Firefox::Tab Candy.  Filter the bugmail spam with "tabcandymassmove".
Component: TabCandy → TabCandy
Product: Mozilla Labs → Firefox
Target Milestone: -- → ---

Updated

8 years ago
QA Contact: tabcandy → tabcandy

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Bug 575851 isn't closed yet. Is this specific bug actually resolved on trunk?
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.