Closed Bug 566764 Opened 9 years ago Closed 9 years ago

Stuck "Updating add-ons" when no add-ons installed

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla1.9.3a5

People

(Reporter: bparr, Assigned: bparr)

References

Details

(Whiteboard: [rewrite])

Attachments

(1 file, 2 obsolete files)

In the Add-ons Manager rewrite, when no add-ons are installed (fresh profile), clicking the "Update add-ons" link in the main header causes it to (seemingly) get stuck "Updating add-ons".

Reproducible: Always
Blocks: 550048
Whiteboard: [rewrite]
Assignee: nobody → bparr
Attached patch Simple patch (obsolete) — Splinter Review
Attachment #446589 - Flags: review?(dtownsend)
Comment on attachment 446589 [details] [diff] [review]
Simple patch

Blair, can you take a look at this please?
Attachment #446589 - Flags: review?(dtownsend) → review?(bmcbride)
Attachment #446589 - Flags: review?(bmcbride) → review+
Comment on attachment 446589 [details] [diff] [review]
Simple patch

Sorry, went to get this ready to land and noticed that the indentation is wrong, can you correct it please Ben?
Attachment #446589 - Flags: review+ → review-
Attached patch Simple fix (updated) (obsolete) — Splinter Review
Fix spacing issue
Attachment #446589 - Attachment is obsolete: true
Attachment #447109 - Flags: review?(dtownsend)
Comment on attachment 447109 [details] [diff] [review]
Simple fix (updated)

Looks like you've moved the code inside the forEach loop now which I don't think is right.
Attachment #447109 - Flags: review?(dtownsend) → review-
Attached patch Simple fixSplinter Review
Attachment #447109 - Attachment is obsolete: true
Attachment #447114 - Flags: review?(dtownsend)
Comment on attachment 447114 [details] [diff] [review]
Simple fix

Thanks
Attachment #447114 - Flags: review?(dtownsend) → review+
Landed: http://hg.mozilla.org/mozilla-central/rev/b70ac3462181
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a5
Verified fixed with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a5pre) Gecko/20100526 Minefield/3.7a5pre

Possible to test with an automated test?
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
Flags: in-litmus?
Flags: in-litmus? → in-litmus?(vlad.maniac)
(In reply to comment #9)
> Possible to test with an automated test?

Dave, something which could easily be done?
Should be testable yes
Flags: in-litmus?(vlad.maniac) → in-litmus-
You need to log in before you can comment on or make changes to this bug.