System Preferences Keyboard Application Shortcuts show on FF menu but not used

RESOLVED DUPLICATE of bug 429824

Status

()

defect
RESOLVED DUPLICATE of bug 429824
9 years ago
9 years ago

People

(Reporter: mytwhite, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

I am running Mac OS X 10.6.3. Under System Preferences - Keyborad Shortcuts - Application Shortcuts I add menu items like Cut, Paste, Copy, etc.. and change the Keyboard short cut to use ^X, ^V, ^C, etc... These new shortcut keys appear on the Firefox Menu, but when I use them, the Parent Menu flashes blue color, but action is not performed. However, If I use previous keyboard shortcut setting such as %X,%V,%V, action works even though new keyboard shortcut is displayed in menu item.

Other browsers on same system show menu item change, however action does work.
For FF, it seems like the menu keyboard shortcut displayed is disconnected from the function intended for it.


Reproducible: Always

Steps to Reproduce:
1.On mac os X, open System Preferences / Keyboard / Keyboard Shortcuts.
2.Highlight Application Shortcuts. Click plus sign. Add Copy for Menu Title. For Keyboard Shortcut box, type Ctrl C then click the add button.
3.Observe FF "Edit"menu has now new key shortcut listed.
4. Highlight something in a FF window, press Ctrl-C to copy.
5. Give focus to another application and do a paste.
6. Add other Menu shortcuts in Step #2 above, like Paste, Cut, and observe same behavior.
7. Try using Command-C, Command-V, and Command-X now that the shortcuts have changed.  You will see that the Command keys still work, but CTRL keys don't.
8. close and restart FF, or reboot system and notice same behavior.
Actual Results:  
Edit Menu items like Copy, Cut, Paste do now work when keyboard shortcut is changed, but new shortcut is displayed.

Expected Results:  
Expect Edit Menu item shown key for items such as Copy, Cut, and Paste to work with Keyboard shortcut displayed by FF.  It works with Safari, Chrome, and Opera.

Shortcut should have provided assigned action from previous shortcut to newly assigned shortcut.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429824
You need to log in before you can comment on or make changes to this bug.